Cubase 9.5 brand new unable to activate

I went through the process of obtaining an activation code for my PC version of Cubase 9.5 on Windows 10 which I just bought yesterday. The activation code was generated and installed successful, and I clicked the final activation button once it was done. When I try to launch Cubase now I get the “No valid license found” popup box and of course, it won’t accept my old activation code.

So, I tried to go through the Regenerate an Activation Code process, which asked me for my elicenser Software License which was fine until I reached the reactivation cod page which requires me to generate a new eLicenser Software license, which I did, but never received so now I can’t get a new activation code.

What do I do next? I never would have bought this software had I known that Steinberg has the most outrageous registration I have ever encountered in over 30 years of computer experience - and it doesn’t work


There’s Cubase AI, LE, Elements, Artist, Pro. Are you certain the installed program matches the license in the Elicenser Control Center?

I think that is the problem - I installed Pro instead of AI. There should be a more descriptive error message than “No vald License Found” if it’s the wrong version of the program. With such a complicated activation process you should be able to tell someone if they are trying to activate the wrong version. I presume the activation code will not work when I try to install AI, since I used it (and why did it say “success” if it wasn’t the right program?).

My next question is when I uninstall Pro, should I also uninstall all of the extras like “Groove Agent” that were installed with it?


Uninstall everything from Cubase (but keep the elicenser software), reboot your computer and then install Cubase AI. You don’t need to do the activation process again.

OK so I did that - uninstalled all of the Pro components and installed AI and it started to launch with the Cubase AI screen and said loading plugins and then nothing. So I ran the license eLicenser synchronization and it launched and crashed and created a crash dump (.dmp) file. What next? Maybe I shouldn’t have installed the update?


post your OS and system spec.

It’s Windows 10 on a Dell PS7G Inspiron laptop - only a couple of years old.

Sounds like you manually deleted things, rather than using the Windows Program/Apps and Features control panel and letting it do the housekeeping. could that be what’s going on?

If so, maybe if you
-uninstall AI,

  • install Pro again,
  • then uninstall it

You can install AI and get a working setup. Worth a shot.

Tried that, it didn’t work. It opens the program, popus up the error message, and freezes, with “connecting” displayed on the left panel (I have it connected to my new UR44). So where do I send this dump report?

In a support request in your Steinberg account.

OK I finally got it setup, with the issuing of a new license and activation code, and I had to manually delete the Flux presets.

The problem occurred because I downloaded the wrong version of Cubase, which was easy to do when faced with 22 separate products to download in the Download Assistant. And to add to that, when I used the activation code it said that it was activated successfully - no errors were reported.

Oddly, there was no mention of the need to separately install a Steinberg USB driver until an error came up when I tried to install the UR44 firmware update.

With such a sophisticated licensing system I think that if someone purchases the UR44 unit, as I did, that you should be taken directly to the correct version of the software instead of being forced to install the Download Assistant program. And then if the activation code you are given does not match the version you are installing it should indicate that right away.

Thanks for your help.

Please how d i do a support request . i get no options ?? thanks ws.

Go to your MySteinberg account and login, then click the My Support menu button. Simple as that.

thankx finally got it thru asknet, but still no solution to my problem 5 days on ??? but thanks …