Cubase 9.5 doesn't start at all

Cubase 9.5 doesn’t start at all. I intalled it on Disk D. It starts initializing and after 2-5 seconds disappear. I tried to reinstall many times.

I see eLC. Then it says loading something … eLC. And it’s crashed. I don’t know it it’s really about eLC or something else cause it’s so fast. It’s impossible to say certainly. But seems like eLC problem. But all my previous Cubases 8, 8.5, 9 work fine. I updated ELicenser but the same. Any thoughts?

Sorry. I noticed it was the next step. So the crash is related to “Loading GUI resources”

Seems like multiple people have the same problem, Steinberg fix it FAST please, we already paid!

Same issue for me on Windows 10… I just updated to 9.5 from 9.0 and it does not start at all. No splash screen displayed, nothing… just crashes instantly. Windows event viewer says:

Faulting application name: Cubase9.5.exe, version:, time stamp: 0x59e6a397
Faulting module name: Cubase9.5.exe, version:, time stamp: 0x59e6a397
Exception code: 0xc0000005
Fault offset: 0x0000000001c6073e
Faulting process id: 0x3d88
Faulting application start time: 0x01d36464771c7db0
Faulting application path: X:\music\Cubase\Cubase9.5.exe
Faulting module path: X:\music\Cubase\Cubase9.5.exe
Report Id: e17048b8-6b6a-4df0-9c31-acbdbaf13231
Faulting package full name:
Faulting package-relative application ID:

And thats it. :frowning:

If I analyse the waiting chain in taskmanager, its says that cubase9.5.exe is waiting for synsopos.exe. I know thats the elicenser server or something like that. The strange thing is, if I start Cubase 9.5 all licenses disappear in the elicenser control center and it says “Reading elicenser…” but does not finish anymore. Already tried to reinstall eLicenser, but nothing changes.


I have this issue too… wonder what it is. Every single other program and steinberg cubase version including 9.0 works fine.

ok guys found the exact issue. Similar to Presonus Studio One 3 requiring KB2670838 windows update… try installing this package from this link:

make sure to reboot. then you should be able to launch Cubase. I am guessing this is now required… Steinberg should say something. I’ve avoided this particular update for years because GUI is a tiny bit snappier without it… but I’ll try the new cubase and see if I like. Good luck fellows.

Won‘t help, because I am on windows 10, and The Patch is windows 7. :frowning:

That’s too bad man. try updating other patches in windows… other than that hope they can fix it so i can get rid of this patch I installed. I like OLD windows. Snappy and simple.

Windows 10 also the latest update 1709… I can load 9.5 but cannot load anything wont go past the hub and when i kill the hub in taskmanger and try to load a empty project it a blank template nothing there cannot launch perferences

Ok, problem solved. I deinstalled Cubase and downloaded the 9.5 Full Installer instead of the 9.0 to 9.5 Update package and did a fresh install. Now it starts without issues.

I started this thread and I needed only Windows 7 update. It works. But a lot of bugs.
External hardware doesn’t work in 9.5. I had it good working in 9.0
I create external plugin in F4 menu. I name in X. But in Steinberg plugin list it’s named Z. When I delete external “X” it give crushin error.
You’d better test you DAW before selling it. I didn’t pay for 9.5 to be your tester. And “Measure FX loop for Delay Compensation” button DOESN’T work
Always worked in every previous Cubase but in 9.5 it doesn’t work. Plus 16 inserts and no option for 8 inserts drives me crazy.

Windows 10 up to date any windows setting change for 9.5 because nothing change for 9.0.2 and all prjects load blank fesh install same problem… when i try to load a project the hub launches then when i go to the projext folder it loads vut blank windows

Mark try going to program files / steinberg / cubase 9.5 / components/ and renaming videoengine.dll to .bak (basically disable it temporarily on boot). you could try other dll components one by one to see if anything is responsible. Definitely try hubservice.dll and files with a very old date (that might have gotten automatically moved from an old cubase installation during install). Other than that, I’m fresh out of ideas.

I have installed updates, I have installed the full version of Cubase, I have done everything I could and the problem is still there. It starts to boot and after 2 seconds it closes without error message. I’ve been waiting for a solution of Steinberg for days.

Have the same problem. After few second after opening the progect it closes. Same laptop. Never has it with Cubase 8.0, 8.5, 9.0.
Crash dump:

Bummer guys. I’ll be monitoring this to see if Stb can fix in the first update.

maybe it helps… I can work with Cubase 9.5 but only when I start the program with integrated video card (intel HD3000). Second video card is GeForce M520. When I open without choosing video card - crash every time after few seconds.

Same here,
So far I have:
Installed .NET Application file
Installed latest service pack for Windows 7 Ultimate
Installed various files/applications from suggestions on other threads with Similar problems. (I’ve read them all!)
Deleted the Selicerser file (which was empty)
Installed this … x?id=36805
Installed latest Nvidia graphics card drivers.
Updated eLicenser to latest version and performed check

Its still stops at loading GUI. Cubase 8.0 still opens with the eLicenser warning so I guess its not that.