Cubase 9,5 eLicenser issue - LCC2 error message

After working for about two years, my Cubase has stopped working. There seems to be an issue with the elicenser. This happened after an windows update on the 17 of July, so I am not sure if this has anything to do with it.

I get the error messages such as:

  1. “Application ‘LCC2’ has caused the following error. An unknown interapplication communication error occured. In case the problem persists, please close all applications and restart your computer.”
  2. Soft elicenser doesn’t have enough permissions to run properly. Please run LCC to fix this problem. --> I thought I did not even use the soft elicenser when I open Cubase 9,5, only the USB dongle?

I have been back and forth with support trying all kinds of things:

  • Uninnstalling elicenser,
  • Running elicenser as administrator --> Doing maintenance test.
  • Running cubase as administrator
  • Bought a new dongle and transferred my license there.
  • I also tried DEP but i was unable to turn off DEP for the elicenser (“Data Execution Prevention This program must run with DEP enabled. You cannot turn off DEP for this program”)

I am running on Win 10 64 bit.

I sent Steinberg my system file and they claim that my USB ports are not compatible with Win 10. I find this strage becauase I have used Win 10 since 2015 and Cubase for two years with these ports. Seems to me they just want an easy way out and that they are not able to solve the problem. But perhaps also there could be an issue with the USB port that makes the elicenser and Cubase unable to communicate due to the latest win update?

Anybody who can help?

Hi,

What error message exactly do you get, please?

Btw, this is Cubase 10 forum, not Cubase 9.5.

I get the error messages such as:

  1. “Application ‘LCC2’ has caused the following error. An unknown interapplication communication error occured. In case the problem persists, please close all applications and restart your computer.”
  2. Soft elicenser doesn’t have enough permissions to run properly. Please run LCC to fix this problem. --> I thought I did not even use the soft elicenser when I open Cubase 9,5, only the USB dongle?

Also very often the dongle is not shown in the elicenser and all fields are marked grey.

Cubase is starting, but somewhere in the startup process it stops responding. Seems to be issues in the communication with the elicenser.

Hi,

Some Windows updates break the Soft-eLCC. Even if you don’t use Soft-eLCC, the Soft-eLCC is there.

Quit Cubase (all Steinberg applications). Right-click to the eLCC and start it as administrator. Trigger Maintenance. Does it help?

I updated my first post now. NO, I have tried that countless times. Not helping.

Hi,

How old is your USB-eLicenser? Is it connected to USB 2 or USB 3 port, please?

I am using the latest version of the elicenser and my USB licenser was about 2 years old. However, I just bought a new one, but the problem is still there.

Hi,

I have to say I’m out of ideas, sorry. Have our risen Steinberg support ticket, please?

Steinberg blames it on my USB port and says Win 10 does not support it. Seems they just want an easy way out. I have used Win 10 and those USB ports for years with Cubase. Why did they work in the past if that was an issue?