Cubase 9.5 hangs on project close on Win 10

As I still have this problem, I’m gonna bump this thread :slight_smile:
By taking memory dumps in the deadlock state and looking at a threaddump in windbg, I’ve narrowed the problem down to the following plugins
Shattered Glass audio’s SGA1566 and Tonebooster’s plugins (the v3 ones, not the JUCE ones).
I think this is the thread where it somehow goes wrong:

  0  Id: 371c.4908 Suspend: 1 Teb: 00000000`00234000 Unfrozen
 # Child-SP          RetAddr           Call Site
00 00000000`0014e818 00007ff9`332d9252 ntdll!NtWaitForSingleObject+0x14
01 00000000`0014e820 00007ff8`dbd08c7d KERNELBASE!WaitForSingleObjectEx+0xa2
02 00000000`0014e8c0 00007ff8`dba5e576 D3D10Warp!ThreadPool::WaitWhileBusy+0xdd
03 00000000`0014e940 00007ff8`dba2cba6 D3D10Warp!UMContext::FlushAllRenderingTasks+0xfc6
04 00000000`0014f1e0 00007ff8`dba2ac38 D3D10Warp!UMDevice::Destroy+0xb6
05 00000000`0014f2c0 00007ff8`dba38185 D3D10Warp!UMDevice::`vector deleting destructor'+0x28
06 00000000`0014f300 00007ff9`2ff20b7c D3D10Warp!UMDevice::DestroyDevice+0x55
07 00000000`0014f340 00007ff9`2ff233b8 d3d11!NDXGI::CDevice::DestroyDriverInstance+0x5c
08 00000000`0014f3a0 00007ff9`2ff1763a d3d11!CContext::LUCBeginLayerDestruction+0x7c
09 00000000`0014f3f0 00007ff9`2ff17982 d3d11!CUseCountedObject<NOutermost::CDeviceChild>::UCDestroy+0x19a
0a 00000000`0014f420 00007ff9`2ff2e2ab d3d11!CUseCountedObject<NOutermost::CDeviceChild>::UCReleaseUse+0xb2
0b 00000000`0014f450 00007ff9`2ff1b100 d3d11!CDevice::LLOBeginLayerDestruction+0x11f
0c 00000000`0014f480 00007ff9`2ff17ef5 d3d11!NDXGI::CDevice::LLOBeginLayerDestruction+0x10c
0d 00000000`0014f4d0 00007ff9`2ff17dab d3d11!NOutermost::CDevice::LLOBeginLayerDestruction+0x25
0e 00000000`0014f500 00007ff9`2ff17cf4 d3d11!TComObject<NOutermost::CDevice>::~TComObject<NOutermost::CDevice>+0x23
0f 00000000`0014f530 00007ff9`2ff17d74 d3d11!TComObject<NOutermost::CDevice>::`scalar deleting destructor'+0x14
10 00000000`0014f560 00007ff9`2ff584bb d3d11!TComObject<NOutermost::CDevice>::Release+0x44
11 00000000`0014f590 00007ff9`2ff14934 d3d11!ATL::CComPtr<IUnknown>::~CComPtr<IUnknown>+0x4b
12 00000000`0014f5d0 00007ff9`302b0921 d3d11!CLayeredObjectWithCLS<CBuffer>::CContainedObject::Release+0x2c4
13 00000000`0014f620 00007ff9`302f4859 d2d1!CHwSurfaceRenderTargetSharedData::~CHwSurfaceRenderTargetSharedData+0x1f5
14 00000000`0014f650 00007ff9`302f4907 d2d1!InitializableObject<RefCountedObject<CD3DDeviceLevel1,LockingRequired,DeleteOnZeroReference> >::`vector deleting destructor'+0x29
15 00000000`0014f680 00007ff9`302f4ed9 d2d1!RefCountedObject<CD3DDeviceLevel1,LockingRequired,DeleteOnZeroReference>::Release+0x47
16 00000000`0014f6b0 00007ff9`302f3991 d2d1!CD3DDeviceManager::D3DDeviceInformation::`scalar deleting destructor'+0x2d
17 00000000`0014f6e0 00007ff9`302709f4 d2d1!CD3DDeviceManager::~CD3DDeviceManager+0x71
18 00000000`0014f710 00007ff9`302b58d0 d2d1!D2DFactory::~D2DFactory+0xbc
19 00000000`0014f750 00007ff9`302b58b9 d2d1!RefCountedObject<D2DFactoryLocking<MultiThreadedTrait>,LockingRequired,DeleteOnZeroReference>::`vector deleting destructor'+0x14
*** WARNING: Unable to verify checksum for C:\Program Files\Vstplugins\!Guitar\SGA1566.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files\Vstplugins\!Guitar\SGA1566.dll - 
1a 00000000`0014f780 00000000`7f47695a d2d1!RefCountedObject<D2DFactoryLocking<MultiThreadedTrait>,LockingRequired,DeleteOnZeroReference>::Release+0x39
1b 00000000`0014f7b0 00000000`7f5e59b3 SGA1566+0x5695a
1c 00000000`0014f7f0 00000000`7f5dcf4e SGA1566!VSTPluginMain+0x164463
1d 00000000`0014f860 00000000`7f5dd117 SGA1566!VSTPluginMain+0x15b9fe
1e 00000000`0014f890 00007ff9`36f04053 SGA1566!VSTPluginMain+0x15bbc7
1f 00000000`0014f900 00007ff9`36f0ff71 ntdll!LdrpCallInitRoutine+0x6b
20 00000000`0014f970 00007ff9`36f0f59e ntdll!LdrpProcessDetachNode+0xf5
21 00000000`0014fa40 00007ff9`36f0f945 ntdll!LdrpUnloadNode+0x3e
22 00000000`0014fa90 00007ff9`36f0f8c3 ntdll!LdrpDecrementModuleLoadCountEx+0x71
23 00000000`0014fac0 00007ff9`332bbced ntdll!LdrUnloadDll+0x93
*** WARNING: Unable to verify checksum for C:\Program Files\Steinberg\Cubase 9.5\Components\VSTPlugManager.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files\Steinberg\Cubase 9.5\Components\VSTPlugManager.dll - 
24 00000000`0014faf0 00000000`19256f3a KERNELBASE!FreeLibrary+0x1d
25 00000000`0014fb20 00000000`192572c0 VSTPlugManager!InitDll+0x330eb
*** ERROR: Module load completed but symbols could not be loaded for C:\Program Files\Steinberg\Cubase 9.5\Cubase9.5.exe
2a 00000000`0014fc30 00000001`418f6c4f VSTPlugManager!InitDll+0xc6d9
2b 00000000`0014fc60 00000001`418fc014 Cubase9_5+0x18f6c4f
35 00000000`0014ff60 00007ff9`36f41461 KERNEL32!BaseThreadInitThunk+0x14
36 00000000`0014ff90 00000000`00000000 ntdll!RtlUserThreadStart+0x21

Other times, it’s

*** WARNING: Unable to verify checksum for C:\Program Files\Vstplugins\ToneBoosters\TrackEssentials_v3\TB_Compressor_v3.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files\Vstplugins\ToneBoosters\TrackEssentials_v3\TB_Compressor_v3.dll - 
1b 00000000`0014f650 00007ff9`09344c7a d2d1!RefCountedObject<D2DFactoryLocking<MultiThreadedTrait>,LockingRequired,DeleteOnZeroReference>::Release+0x39
1c 00000000`0014f680 00007ff9`33a31243 TB_Compressor_v3!VSTPluginMain+0x4390a

or other TB plugins.
I’ve opened a call at Tonebooster’s, Jeroen was very quick to answer, but sadly cannot reproduce the problem (well, I don’t know yet how to exactly reproduce it, except work for some longer time on a project with the mentioned plugins and then close it…)
I’ve opened calls at Steinberg, but so far all they did was put the blame on a third party plugin (the wrong one).

This problem happened so far with all updates of C9.5 and all revisions of TB plugins this year.

Can i really be the only one with this problem???

1 Like

So Steinberg Support says that this is the fault of some Direct-X module, probably because it is old (the stack trace has some calls to Direct-X Libraries (d3d10warp.dll etc), Which seems kind of odd because Direct-X is a window system component and gets updated with windows updates, and I have the latest installed. But they’ve been wrong before…
Could anyone on a current Windows 10 please do me a favour and check for the following DLL versions in c:\windows\system32? (right-click “properties”, then go to details)
D3D10warp.dll - 10.0.17134.112 from 8th of June 2018
d3d11.dll - 10.0.17134.407 from 1st of November
d2d1.dll - 10.0.17134.407 from 1st of November

1 Like

Most interestingly this behaviour does not happen at all in Reaper or Studio 1… I can use all those named plugins, and I never get any hang during a project close… and how fast those are!

This still happens even after installing a fresh new Windows 10 from a current Media Creation Tool with only Cubase 9.5.41, the specific plugins and the RME driver installed.
Is there really no one else having this kind of problem??? I cannot imagine that, i mean, my setup isn’t that special - an Intel 8700K system with Win10, a Fireface UFX, VST2 Plugins from Toneboosters (the V3 ones), Tokyo Dawn Labs (Slick EQ GE) and SGA.
But as soon as I add those VST plugins to a project and work on it for some time, when closing the project Cubase hangs and has to be killed…

It seems that no one here has the problem, which is still weird, but there might be a solution to this problem:
I’ve been in contact with a plugin developer and he provided me with a version of his plugin (one of those that caused the hang) compiled with VSTGUI 4.3 instead of 4.0, and with that version I never had the hang state so far.
The culprit is probably vstgui/lib/platform/win32/win32support.cpp, there is a commit that looks suspiciously related to the problem:
This seems to be related to DirectX, but a some questions remain:

  • Why do so few users encounter the problem on Win10?
  • Why is it only Cubase that has the problem but not Studio One or Reaper (which I tested here on my machine to see whether they show the same behavior)
  • Was there a change in Direct-X from Win7 to Win10. I never had the problem on Win7 which I used until February (on my old machine)

Same problem here.
Cubase 9.5 hangs on Windows 10 when closing project. I have same ver. on OSX and is OK.

I also got the same problem… since today… i saw that when i open the task manager to end cubase there (as it doesn´t respond) that there´s
still a background process from cubase running that can´t be closed immediately. when i start cubase again it seems that the driver of my Steinberg UR22 has been killed by this also


Could you attach an affected project, please?

I updated to Cubase 10 yesterday - (for now) the driver doesn´t get ´thrown out´ when i close it like with cubase 9.5.41 before, but i still have to close it in the task manager, as when i close it with ctrl + Q it closes the project, but cubase itself gives no response according to the task manager.
And this only happens when i work on the Project for a while - when i just open it and close it Cubase closes normally.
You still need that project?

Would be nice to have an option to try.

If you would know, what steps to do to evoke the situation while quit, that would be great.

I worked on the project again for about two hours yesterday, and cubase closed normally afterwards now. hmm… weired.
i´ll observe it the next few days and if it happens again i´ll get back to you. thanks for your advice in the meantime!

Sooo… i worked on different projects today and everything worked (almost) fine (except one more forced shutdown of Cubase), and now
suddenly the insert effects get transparent again… on all projects! so it´s not the project, but what could it be?
I´ll attach a screenshot, so you can see it Martin…


Can you please click to the “e” button of the plug-in? Does the plug-in GUI appears? How does it look like? Can you attach the screenshot with the opened window, please?

I tried to uninstall and reinstall interface driver, midi controller driver, some plugins - still the transparent insert effects. but then without
any obvious reason when i restarted it another time the insert effect colour appeared again. and today… it´s again gone (see screenshot).
when i load the plugins they look normal tough. i don´t know if there are other changes to cubase 10 as i didn´t work for long with these transparent insert effects.
is it possible to move this topic to another category - as it is no longer about cubase 9.5 hanging?

I just found out it might be connected with the waves plugin ´element 2´. i uninstalled it and afterwards cubase 10 didn´t have this
tansparent insert effects anymore - at least for now it doesn´t.

Interesting. The was a similar thread. The user said this happened with some freeware plug-ins. After uninstalling of these gate plug-ins the issue disappeared. Same as yours issue with Waves plug-ins.

If you open the Windows Task Manager, does it say something like “inactive” as the state for Cubase? If yes, it might be the same problem as I have, but you can only be really sure if you install windbg and have a look at the stack trace (which isn’t for the faint hearted).
Or you take a memory dump of Cubase when it hangs- For that you go into the Windows task manager, right click Cubase process and select “Create dump file”. Task Manager will tell you where the dump was written (usually “C:\Users\yourusername\AppData\Local\Temp\Cubase9.5.40.DMP”).
Put it someplace where I can download it and send me a link and I can probably tell you which plugin it is…
Do you use any of the plugins I mentioned above? It was a bug in earlier versions of the VSTGUI Framework some plugin developers use.
If you use Tonebooster plugins, get the latest version, they’ve fixed it (Thanks TB!).

Hi there, I’ve the same issue but I’m on a mac with macOS Sierra. I don’t have issues if I work on projects with only audio files. If I start to use Spitfire Audio libraries the issue rises. And like in your case if I attempt to close the project after a few minutes it closes well. If I try to work for more time the project hangs by closing.
For sure we are using different plugins, we are on different OS systems with different libraries. The only stuff we are sharing is Steinberg’s software. The common sense let me suppose hat the issue is not in our projects or computers but by Steinberg. I mean, maybe…
But I really don’t know how to find a way to fix this.

In the end it way actually some plugins (several from different vendors which made it hard to find…) that were the culprit. Some of those bugs were fixed, one other that didn’t get fixed I just didn’t use anymore until I tested it again a few weeks ago with Cubase 10.5 and suddenly no problem anymore, no deadlocks.

Similar thing happened when sonible release their smart:comp, there were actually several users on gearslutz who had the “Cubase hang” problem with it, and the developers had a hard time finding the bug. Very esoteric.
Cubase seems to handle plugin/dll unloading differently than other DAWs. I’ve never heard it happen on MacOS, though.

Hi fese. Did you ever get to the bottom of this? I’m here in Feb 2021 after dealing with what seems the same for over a year. It happens with Acustica Audio plugins in my case. There are a number of reports of it, had numerous tickets opened. Support found the D3D10Warp.dll problem and once more we seem to be at a dead end.