Cubase 9.5 Midi Input Transformer Bug???


I’m trying to use a preset I’ve previously created using the Midi Input Transformer to control Aftertouch with a midi fader.
This worked perfectly in version 9. Since upgrading to 9.5 the preset no longer works.

The preset setup transforms midi cc75 (from my fader) into Aftertouch. I have tested using midi monitor to track incoming midi data. With Input Transformer set to Off, midi monitor shows it’s receiving cc75. With Input Transformer set to local, and with the module disengaged, I show the same incoming midi data. Once the module is engaged I no longer receive any incoming midi data. I would be very appreciative if anyone could confirm this behavior or offer a solution. Thanks!

Midi Input Transformer setup:
Type Is - Equal - Controller
Value 1 - Equal - cc75

Value1 - Use Value2
Type - Set to Fixed value - Aftertouch

After further testing I’ve found that changing “Aftertouch” in the bottom half of the Input Transformer to any of the other options (note, poly pressure, controller, program change, pitchbend, VST3 event) all respond correctly in the midi monitor. Also, I found I can record the fader (cc75) in the midi cc lane as aftertouch and reads back correctly. Problems stills remains that performing live the input transformer isn’t correctly transforming midi cc into aftertouch.

Any thoughts would be greatly appreciated!


It works to me as expected, here.

Thank you for responding, I appreciate the help!

Can you please confirm you are testing in version 9.5? It works for me in version 9 but not in 9.5.
To reproduce (9.5):

  1. Add Midi track
  2. Select Input Transformer - Local
  3. Apply the preset above.
  4. Engage the module 1 button.
  5. On the midi track select MIDI Inserts and choose MIDI Monitor.
  6. Move a Midi fader with the corresponding midi channel in the preset.
  7. Check to see if you’re receiving midi data.

For me, with Module 1 of the Input Transformer engaged, I receive no Midi data. With it disengaged, I show that I am receiving midi data from the fader.

I can confirm, I test in on C9.5.

I was using Global Transformer. Now I tested with Local. The result is the same. It works.

Could you try to apply preset Controller Filtering > Filter Modulation? Change the value to MIDI VV75, you are using. Does this work? When you adapt this preset to your:
Value1 - Use Value2
Type - Set to Fixed value - Aftertouch

Does it work now?