Cubase 9.5 Terrible GPU Performance

Just upgraded to Cubase 9.5, and experiencing some truly epic video issues. I’m getting like 4 fps on scrolling and meter performance while playing back a minimal session. This is on a system with a GTX 970. Cubase 9, incidentally, runs fine.

Was a “slide show mode” preference added somewhere I can disable lol?

Is this on Windows or are you still using a Mac? For me the demo project runs at almost constant 60 FPS on a much weaker GPU, which wouldn’t be possible on any previous Cubase version.

9.5 includes graphics performance improvements which benefits both OSes, but are specially noticeable on Mac.

This is actually Windows 10 running via Bootcamp. Might be the cause of it, but never had issues before with video performance…drivers are all up to date.

So no one here is experiencing slow UI performance on Windows 10 using an nVidia GPU?

No it runs faster than ever before, around 60fps.

Well, I feel like my GTX 970 should be more than adequate (it obviously is.)

Anyone having issues (or not) with multi-monitor setups? I have three monitors going…

Nope, Have a 1080 and its fine… be supprised if it wasn’t to be honest.

I had issues wit really bad GUI performances in Key Editor. It appears that it was related to plugins. Finding the offending ones and uninstalling them completely fixed the issue for me. So you could try to completely remove all plugins used in your project and see if you get any improvement.

It appears that it was related to plugins.

Care to share which ones on your end?

Also, here’s a video of the issue for those who are curious. Yes, performance is particularly terrible in the key editor, but overall pretty bad.

Sorry to say it but 9.5 is proving to be the best performing update so far for me. I abandoned Nvidia a while ago because of a number of issues

You really should just contact support directly through your MySteinberg.

I’m experiencing the same problem with GeForce GTX980.
It seems that Cubase9.5 has some issues with nVidia graphic card since there is a article on the website:

That’s an unrelated issue.

I’m not getting the same as you but I am getting stutters and glitching doing any graphic intensive tasks (opening a plugin window for example). Don’t get this on 9.0.30. It;s worse when video is playing back.

However, I’m on an ancient radeon Hd 5450. Just trying to get to the bottom of it…

Someone managed to fix this by disabling NVIDIA ShadowPlay.

You’re not alone. I just upgraded to 9.5 and have an Nvidia 1080 running 4 monitors and the GUI slowdown is a huge problem for me currently. What’s weird is that audio is fine and performance meters are in better shape than previous versions but I recently had to do a quick scoring to video project and the GUI would progressively slow as the project played until it was totally unusable. I could make it better by closing some windows (mixer, Kontakt windows, video) but that’s obviously not a preferred solution. It was even worse with 64 bit processing enabled. The weird thing is that when the project first starts playing it’s fine but then starts getting slower and slower until it’s just a mess.

I hope there is a solution either on the Steinberg or Nvidia side because otherwise the program is not workable for me. Haven’t had the chance to try it in 9, though the GUI was noticeable a bit sluggish especially with scissor tool.

Well stationary curser is laggy in 9.5 that needs to get fixed, but everything else is snappy here.
Automatic hitpoint detection is off, as I had some issues using lots of tracks with lots of events made the GUI laggy.