Cubase 9.5Pro won't route to laptop headphones

Normally I mix on my nice big monitors on my desktop PC through Focusrite.

I’m trying to set up CB9.5Pro on my laptop as a mobile mixing device.

But it wont route the audio through the laptop speakers.

I’m using the generic ASIO driver on the laptop, the only one CB offers. But the sound insists on coming out of the crappy laptop speakers, even when I have my studio quality headphones plugged in.

I’ve checked the Audio Connections and VST connections etc, and all is as it should be, but the sound still comes out of the speakers, not the headphones, even with the headphones plugged in.

Has anyone else seen this, and is there a solution?

Download, install and select ASIO4all in place of the generic driver.
Post back if that doesn’t fix the problem.

Good idea thanks.

Unfortunately, exactly the same problem.

I really don’t get this. I’ve been using Cubase and ASIO for donkeys years and never expected a problem like this.

It’s like the headphones don’t exist.

ControlRoom enabled/disabled makes no difference.

ASIO4ALL all configured in CB, headphones plugged in, but the music continues to only come out of the speakers.

If you open ASIO4all control panel do the headphones appear as a separate output?

By chance I’ve been using my Laptop this week using the onboard soundcard and it works fine with either laptop speakers or headphones. If I plug in the 'phones it just switches to them as with any other program (and I get a pop-up to confirm that I’ve plugged in 'phones, again as is usual with this Laptop). I’m using the Generic Low Latency driver, FWIW. (Jut checked ASIO4ALL and fine with that too)

Sounds like perhaps it may be your Laptop or its setup? Does the sound just continue through the speakers when you plug the 'phones in (I think you’re saying yes)? If so does it switch to the phones with other software?


ASIO4All doesn’t list headphones or speakers, just a HIgh Definition Audio Device.

I even went to the Win10 Playback devices control panel and disabled speakers, leaving headphones as the default sound playback device. Cubase still plays through the speakers.

Yet if I play Windows audio it comes through the headphones. Just not ASIO stuff, the very thing I want! :slight_smile:

1 Like

Strange…I’m out of suggestions for the moment, sorry. :frowning:

Shall carry on thinking.

So I disabled the speakers leaving only the headphones in Win10 playback devices, but ASIO4ALL still wouldn’t play to the headphones. So I switched back to Generic ASIO and suddenly I have sound in the headphones.

So I uninstalled ASIO4ALL and tried again. The CB crashed. Doesn’t like not having the speakers enabled it seems.

Generic driver is very crashy with some systems ime…I think you’ll be better off with ASIO4all if we can get round the headphone assignment problem.

In windows audio/advanced properties for both the speakers and headphones could you try to untick “allow applications to take exclusive control of this device” and see if it makes any difference on ASIO4all.

EDIT: Maybe re-check ASIO4all control panel with hp as default device and see if anything is different there.

OK, So then I reinstalled ASIO4ALL, but left the WIn10 playback devices speakers disabled.

Then back into Cubase. ASIO4ALL still plays to the speakers (which are disabled).

So I switch back to Generic ASIO, but do not uninstall ASIO4ALL.

Now I have sound in headphones again.

So in summary, disabling WIn10 playback devices speakers will force the sound to the Generic ASIO headphones, but you can only do this with ASIO4ALL installed, although it is not “in use”, but without it, Cubase crashes totally as it seems it doesn’t like being targetting at a disabled playback device.

Who wrote that line of code - if (unneeded) speakers not available, crash Cubase totally…??

So I have a ‘solution’ of sorts which gets me out of a hole, but it really shouldn’t be like this.

Thanks for listening.

“In windows audio/advanced properties for both the speakers and headphones could you try to untick “allow applications to take exclusive control of this device” and see if it makes any difference on ASIO4all.”

I tried this. Even after restarting CB, no difference.

Glad you got it working even if by such a circuitous route. Presumably not an area that’s been majorly tested…some incompatibility somewhere between your Laptop and the ASIO drivers? Is it generic sound chip do you know? Mines a (pretty common) Realtek HD Audio affair.

It’s just listed in Device Manager as a Microsoft High Definition Audio Device. Laptop is i7, around 4 years old Dell.

Mine’s an i7 Dell too, probably a bit older than yours (5-6 years).


Just looked up the laptop on Dell’s website and found the proper audio driver for it for WIn10x64, a Conexant SmartAudio HD.

Installed this, and now ASIO4ALL works properly, and I get only one playback device in Win10 Playback Devices, and I get headphone sound simply by plugging in the headphones without any mucking about.

So we got there in the end!

So it turns out MicroSnots generic Win10 HD audio driver is a bad thing. Never expected miracles from it, but I didn’t see the headphone problem coming!

BTW, ASIO4ALL and Generic Low Latency Driver all work fine now.

Excellent! Thanks for the update, good to hear and it might help someone else in the future. As Grim suggested you may find better performance from ASIO4ALL, I seem to have ever so slightly lower latency.

Yes, ASIO4ALL halves both the latency, and the CPU usage, so is a good thing compared with the Generic Low Latency Driver, which it turns out isn’t so low.

Heh, heh…yes, not sure why I wasn’t using ASIO4ALL but probably because I don’t often use the onboard soundcard.