Cubase 9 and elicenser server down

After giving Steinberg my money for Cubase Pro 9, I can’t activate it via newest elicenser. error says the licensing server is down. Of course their is no phone support. (Was hoping merger with Yamaha would change that) :imp:
So what am I supposed to do? You would think long time customers would be able to get support.

I’m having the same problem. The eLicenser Control Center tries to synchronize with the server but then fails during the last step.

I’ve tried it about a dozen times in the last few hours, but get the same result every time (and I have the latest version of the software installed, v6.10.4.1203, so that’s not the issue).

Lame. The shopping cart to take our money always works flawlessly. lol

Same here. Hopefully it will be up soon? Pretty shitty, though. Wish a moderator would chime in with some info.

Had, that problem a few hours ago also…

But,an hour ago it worked fine, i suppose because of the email i got today from steinberg about cubase 9
forgot to activate 8.5 lol
Saw that there an grace update, so activated to pro 9 :smiley:
Guess a lot of people are use using control center right now haha

Appeared to be working as of this post. Did not complete the operation (failed on the last step). Cubase still opens properly, though.

Still not working for me. Been trying for 2 hours.

Steinberg is silent as usual. I finally got the elicencer to update my 8.5 to 9 upgrade after attempts all day. Now I run the Update installer and all it wants to install is the generic low latency ASIO driver. No Cubase 9 update will install. What a horrible experience. If it wan’t for the forum users, I wouldn’t get any support at all. Is there a full installer available? I removed 8.5 and I see 9.0 took 8.5 license off.

My situation is far worse. I can’t even connect to my elicenser now. When I try, I get an error
'Connection to protection device lost". I tried to connect to it on a PC machine i did not get the error but there are no licenses on the unit now.

the bonus is all my licenses are registered on line.

I opened a ticket with Tech Support


same problem with my e licenser
had to install an older version to get my 8.5 working again , 9 doesn’t work on it.
suggested workarounds don’t work
newest version crashes after filling in the licence code
or no elicenser found …connection lost ???

:smiling_imp: :smiling_imp:


Is that what it is? Server down, or perhaps busy?

Trying to install Elements 9, enter activation code, eliscenser crashes every time. :angry:

Come on Steinberg. :neutral_face:

for my problem was solved with the new elicenser version ( 14 december ) .
dongle found and flawless installation on sierra OS
merry Xmas :smiley:

I should have read this forum before buying Cubase 9 so quick. Regrets.