Cubase 9 and Sierra

I have upgraded my imac to sierra after instralliung cubase 9 upgrade from 8.5 (pro versions)

It starts but when opening it gives me the following message: “could not create record file” and freezes.I have to force quit to exit Cubase.
I have tried starting up in safe mode without success.

Can anyone help? thanks

I will add that both versions 8 and 8.5 work fine

Not sure if this will help but I was having a few issues with Cubase 9 when I upgraded from El Capitan to Sierra. Unfortunately, I was forced to do a clean install of Sierra due to my audio interface and to my surprise, Cubase 9 issues disappeared and my audio interface started working perfect again. Maybe the upgrade from El Capitan to Sierra caused some issues, with El Capitan being the culprit.

I would advice to start off by trashing your Cubase 9 preferences to see it that helps. Make sure to do a backup just in case. Next, try to completely uninstall Cubase and then re-install. Last resort would, could be, a fresh Sierra OS install.

Thankks for the reply evertone, i did re-downolad and install cubase 9 but i still get the same message. You mentioned trashing the preferences; where can i find those?

Just an update: I managed to resolve the problem and am posting it here in case the same thing happens to someone else.
I copied the entire project folder to another disc. The porject opens, the same error message appears but clicking on “ok” this time does not freeze Cubase and the project opens. Once saved, the project will reopen normnally with no error message anymore.
Don’t ask me why, but it works.

it’s crashing on my Mac Pro Xeon chips/Sierra. both 8&9. All fresh installs. I like how Cubase looks and sounds but i don’t see it ever be stable on Macs… The last stable was ver.3. sorry