cubase 9 issue with UR44

have just updated to Cubase 9 and having problems with drop outs and glitches on song playback.
Seemed to remember having similar issues with Cubase 7 but i was using the UR 22 and i eventually got this working smoothly. I needed more inputs (dont we all) so upgraded to the UR44 . I have downloaded the latest UR44 drivers from Steinberg and installed them to no avail. My question is the UR 44 compatible with 64-bit architecture. When i look in the driver details in win manager the locations are in c/windows/system32/drivers which worries me somewhat.
Windows 7 is updated and a new/clean build. The version of the yamaha/steinberg driver for the UR44 is Cubase has been updated to 9.0.20 and Multi processing and ASIO Guard are both active. Plenty memory, disk space and a good video card all recently installed in preperation for Cubase.
I noticed in YAMAHA STEINBERG USB ASIO menu that externally clocked was,nt checked so checked it to try but failed - have reset back to unchecked as i think thats the default. I,m beginning to check/uncheck things now which i really dont know about so anyone with any ideas can you please advise. Appart from this so far things are looking good and transfers of data from old songs are seamless.
many thanks in advance.
Steve Allan (

Hi and welcome,

Yes, the driver is fully 64-bit compatible. Make sure, you installed the 64-bit version.

Increasing Buffer Size could help.

I would guess if this is a new build the problems are in Windows configuration or Bios settings or is to do with a bit of your new untested hardware rather than in Cubase settings.

Start here:

Thanks for your input guys most appreciated. I think i have resolved the issue. Having ran out of almost all options, i tried various things today even disabling my n/w connection as this is (mostly) a standalone machine and i could easily just enable the n/w as and when i needed it for registration/ upgrades etc. Needless to say it made no difference. I tried a bios upgrade which again did nothing but not a bad excercise anyway. I read some similar issues here and also tried disabling hyper threading but again to no avail. My last resort was to plug the UR44 into another USB port (you,d think i would have tried that earlier) and that may have resolved it as i have played songs from beginning to end with no drop outs or glitches however time will tell. Its been a long week what with the re-instal of windows and all programs but that was necessary as i was running out of disc space. I think a copy of ACRONIS is on the cards.
Thanks and no doubt i,l be back with more queries in the future.
Steve Allan.