Cubase 9 Pro won't list JD-XA in it's instrument list

Hi everyone,

Has anyone had problems connecting their Roland JD-XA to Cubase 9 Pro?

After buying the JD-XA, updating it’s firmware and installing the relevant drivers in Windows, Cubae doesn’t have it in it’s list of instruments to choose from when creating a new Instrument track or midi track.

I can select the JD-XA in device setup for the input and output. When I open a new project, I can see the volume go up and down on the midi activity on the transport bar when I play notes on the JD-XA’s keyboard, and can hear them from it’s phones jack with my headphones.

But it still isn’t listed in the instrument list for me to select it when adding or creating an instrument and midi track.

If anyone can help it would be greatly appreciated, after spending so much money on this synth and Cubase.

thanks in advance for any help.

A couple of questions:

  1. Have you been able to record the audio output from the JD-XA in Cubase?
  2. When you say “does not appear in the instrument list”, do you mean it does not appear as an input option on a new Midi track?

Normally with an outboard synth, the procedure is to create an audio track and a midi track, and route the midi track’s output to the synth. The output from the synth is then returned to the audio track. The option to route the midi output to your synth is created by installing a .vst provided by Roland into a directory that is in Cubase’s vst search path.

I just received an email from a support staff at Roland explaining that the JDXA doesn’t have plugin editing software for Cubase or any sequencer. Which I should have found out before purchasing the JDXA. A real shame.

By Goggling “roland jd xa cubase”, I did find a similar issue on a Roland forum:

It sounds like the user was able to record midi in Cubase and play it back on the JDXA, but was not able to control JDXA program patches via midi. You may want to try your post on a Roland forum particularly if you are simply trying to get midi to play notes.

Ahh I see, thanks for your help