Cubase 9 won't launch - Solved

I’ve downloaded Cubase 9 and the update Cubase, but the software will not launch. It quits every time as soon as it starts initializing. I’ve booted my Mac Pro running El Capitan under safe boot, but still Cubase won’t launch. I can still run Cubase 8.5, but I can’t get Cubase 9 to even start. It quits two seconds after attempted launch. Has anyone else had this problem, and does anyone have suggestions?



Could you run First Aid from the Disk Utilities, please? Does it help?

Martin, yes, I’ve run the Disk Utilities first aid and I also use Clean My Mac, which has repaired permissions and performed a host of other maintenance functions. Cubase 9 will not launch beyond two seconds before “quitting unexpectedly”.

Yes same problem also it keeps asking if i want to register and i already done that.
than it crashes. it runs untill "content"and then it dies.

I’m getting “eLicenser Control - Error” and then I crash. I deleted 9 and reinstalled it. eLicense and mySteinberg show Cubase 9 registered. I have the latest eLicenser.

I’ve deleted and reinstalled Cubase 9, run disk utilities, confirmed the e-license registration, and safe-booted my computer, yet I still can’t launch the software. Unlike those above, I don’t get any kind of error message. Cubase 9 just quits about 2 seconds into launch. Help.


Could you try to trash Cubase Preferences, please?

Where do you find Cubase Preferences for v9?

Start with the Safe Start Mode, please.

Then try Reset Preferences

Tried safe mode. Got small pop up of past files, then crashed.

Try Reset, please. Don’t forget to move (or rename) even older Cubase folders.

I always prefer to rename the folder, or move it, over deleting it. I have a Backup of the original Preferences thanks to this.

Sorry, I have no idea what you are talking about. When I use SAFE MODE, regular mode any mode I still crash.
Cubase 8.5 works with no problem. Could my .dmg be corrupt?

Please, try to Reset Preferences (of all your Cubase versions).

I found the problem. I have a UR 44. Apparently the firmware had to be updated for v9. Now it works.

Good to know. I’m glad it works.

I have the exact problem, I have the UR44 but the latest firmware.

Solved, I think. It’s the UR44 Tools that need to be upgraded, not the firmware.

Martin, your suggestions aren’t working for me. Preferences won’t rebuild unless I can launch Cubase 9. When I remove the contents of the preferences folder and reboot in safe mode, Cubase 9 balks because it doesn’t see valid licenses for Antares and Drum Core, which resulted from booting in safe mode. So that keeps me from opening Cubase 9. Then, when I reboot normally, I have the same original problem: Cubase 9 quits two seconds into initializing, and the preferences are never rebuilt. I’m still stuck with being unable to open Cubase 9. Am I missing something here? Any other suggestions?

@glvaughan: Do you have the latest eLicenser Software? Did you tried starting it and do the maintenance?

Eric, yes I have the current (and latest) eLicenser software. I have run the maintenance routine, which always hangs up on the 5th of the 6 steps (Step 5: FAILED (Recovering License Transactions). I’ve been using eLicenser for years and it has never successfully completed this step (what’s up with that?). Just to be extra sure, I uninstalled eLicenser, downloaded the current software again, and reinstalled the program. Same results all the way around. Still can’t open Cubase 9. All help will be massively appreciated.