Cubase AI 7 and UR22 - 160ms lag?

Hey guys! I just got a Steinberg UR22 audio interface which came with Cubase AI7.

Everything has been great so far. Except one issue - I have about 160 or so millisecond lag when recording, or when outputting through the device (mixer).

Is this normal? For now, I’ve had to modify the track itself to -160 MS for timing purposes. But, I thought these devices were advertised as zero latency?

Any advice or tips would be appreciated,


You can adjust the latency (i.e. buffer setting) to a lower value. Decrease it as low as possible until you start to get crackles, pops, etc. In the Devices Setup, go to the control panel for the audio interface…

Hi Jaslan, thanks for your response.

I’ve tried this already. Sadly, even at the most low buffer setting, there was still the delay. Any other ideas?

If you are running any plugins that introduce latency then that would be the problem.
Either use the constrain delay compensation button or switch off the offending plugins or freeze their tracks or some such work around.

Correct ASIO driver selected?

You may not be monitoring correctly. Make sure youre MIX knob is either all the way to DAW if you want to hear what it sounds like coming out of your DAW mixer. Or all the way to INPUT to hear just the dry signal going in. Don’t “mix” it–kind of a dumb feature. Pardon me if you’re doing that already.