CUBASE AI Code not working Help!

Hi, I have this UR22 USB Interface and Cubase AI came free with it. I was using it for a few years. Now I upgraded my MacBook & trying to download Cubase AI the code isn’t working. Please help me regenerate the code. Earlier I haven’t linked anything with my account so don’t know how and what to do.

Update - Contacted Local Support and Now Problem Solved thanks for you kind help guys.

Contact the Steinberg support.

It depends on where you are located though.

I live in India. mailed the local reseller Yamaha Corp, waiting for the reply. any other way I can generate the code?

Maybe one the moderators here can forward your request.

Have you gone through reactivatiion?

Yes tried many timed, every other option possible. Feels like I’m stuck in a loop.

So when you log into your MySteinberg account on the products page do you see a Cubase AI license there?

There is an extra step on the website now, since the new licensing started, you have to click on this option to view the current licenses:-

Within there you should see Cubase AI registered, and if you expand the selection an option to reactivate the software.

The software e-licenser number will be shown in the E-Licenser software for that machine.

1 Like

Nope ! nothing

It would appear no AI license was registered with your account. Did you maybe have a MySteinberg account registered with a different email address? I have only ever used the one email address with Steinberg and I can see everything I have purchased/registered since 2012.

Yes found in the other mail I had in 2016. Thank you !! :blush:

That’s great news Priyanshu.
Kind regards,

Yes ! Actually I have the MBP 14 Base Variant. I was trying to connect my UR22 Audio Interface but it’s not suporting trying from last 3 days with every solution possible, tried every drivers but the device is simply not reading it. the usb light is just blinking.
Tried connecting with my old Lenovo Laptop with WIN10 and it’s working fine. Can you please HELP ?

I don’t record on a Mac much so I could only point you to the USB driver page:

Make sure you read the linked documents there as there is information about the security settings during installation. I think to you should keep the device unplugged while you’re installing the driver, restart and then plug the device in so maybe uninstall the drivers and start again. Also make sure you choose the right driver for the OSX version you have.

I have heard of other users having the same problem with the UR22 so I would say post another thread over in the Hardware section in this forum under the UR series describing the specific problem.

Also try doing a Google search with something like ‘UR22 blinking light Mac’.