Cubase AI. Problem with the guitar (it squeaks)

Hi there folks.

Recently I’ve got Steinberg UR22 and now I’m trying to connect it to my MacBook AIR 13" and guitar so I can play some rock (I guess). But the problem is that I’m getting some weird squeaking noise only (especially when I touch the strings). After I connected it via Guitar Rig it got even worse.

Key info:

  1. The ASIO drivers is installed.
  2. I’m connecting everything like in a tutorial. Looks like this:

  1. Audio-in and audio-out - using my Steinberg UR22 here.

What else. I’ve noticed that when I add more effects (say Hi to Guitar Rig) it makes things much worse. Anyway even without the effects I can’t hear guitar.

Appreciate any help with the issue!

Does it sound like this?
https://soundcloud.com/jrl-music/saps-demo
Also, lights on dimmer switches, fluorescent lights, and computer screens and components can create various hums and interference.

Yeah, it sounds like the part from 0:10 and till 0:17.

UPDATE. I’ve tried it via Guitar Rig 5 only and GarageBand (that Mac thing yeah). Still the same: squeaking noise, when I play some notes it didn’t even bother to play some sound.

Also I’ve tried to connect it at my teachers home (Windows 7 etc) and it worked. Magic!

In C6 (and maybe C7), there was an option on that device settings tab for “Activate STeinberg Audio Power Scheme (SAPS)”. I don’t know if it even exists in C8. It may be somewhere else or have a different name. Bottom line though is that is changed the performance settings in windows, which you can do yourself. In Windows, I the power settings profiles look for a high performance profile. Particularly, look for a minimum processor state and set it to 100%. I would recommend saving that profile and only using it when needed (like when recording guitar through a high gain amplifier model) because it will generate more heat.

Also, try disabling your WiFi adapter.

Lastly, if you are interested in reading more about SaPS and the CPU stepping, just search the Cubase Forum for “SAPS” and you will find some helpful discussions.

Didn’t find SAPS option on Mac OS.
Tried to disable WiFi adapter - no effect.

I’m kinda frustrated right now, cause I brought it like a month ago and still couldn’t connect it.

Sorry. I forgot you were on Mac when I read the part about the teachers Windows machine. Unfortunately, I imagine Macs don’t give the user the option to change the minimum processor state. Not sure what else to advise. :cry:

It is basically signal noise getting amplified to an audible level. Perhaps using a noise gate might stop it at least during the time when not playing.

Well I finally fixed this.

The problem was in the… cable. :slight_smile:

Anyway thx for the help. You can close this thread now.