Cubase (all versions, incl. 8.0.5) crashing on exit

There are a number of messages about a similar issue, but nothing has helped me. Sometimes I need to put my computer to sleep while Cubase is open. Or I might accidentally put computer to sleep while I forgot Cubase was running. Then, after waking up from the sleep, Cubase is always completely crippled. I cannot exit Cubase 8.0.5 no matter what I do.

I had the same problem with all versions of Cubase I can remember, at least 5, 7 and 7.5. Many times it has been said that the computer should not be put to sleep while Cubase is on. But I still will do so sometimes, there is no way around it. On previous versions of Cubase (7 for example) it sometimes agreed to finally close after waiting upto 15 minutes. Then, suddenly the .exe would just disappear from Task Manager. With 8 it doesn’t exit after any waiting time. Also, closing the project before exiting does not help at all.

Note that there is no exit problem if I don’t put the computer to sleep while Cubase is on.

  1. Is there a way to super-force Cubase 8.0.5 to close? No process killing programs I’ve tried will work. Cubase8.exe is just at CPU 0% and does not respond to anything. Also it’s not possible to load Cubase again at this point. Only reboot helps.

  2. Since this problem has been bugging me for over 10 years already, I wonder if there is never going to be a real fix?

some plug-ins causing crash upon exit. Not Cubase issue

As a workaround you could close the project first and then exit Cubase. That did it for me when I had this problem.

just want to echo this issue, cubase also crashes when idle for a few minutes… not sure what causes this, but would be nice to not have to reboot… my workaround is to autosave every few minutes…

Cubase it would be nice as OP posted to “super-force” Cubase to close, its ridiculous that task manager or any process killing cant end the program… other than that I love C8! thanks for a fantastic creative tool

Yes. I previously forgot to write that it doesn’t help anything to close the project and waiting for 30 seconds before exiting (if I already crippled Cubase by putting the computer to sleep while Cubase was on).

I just tried this: Open Cubase 8.0.5, create an empty new project, put computer to sleep, resume, close the empty project, wait for 30 secs, try to exit Cubase. Nope, it’s completely crashed as previously described.

In this case it might be you audio interface, mine never wakes up in a good mood and crushes Cubase.

I use an app called “Process Hacker” (it’s free on Sourceforge).

I know the name of the app sounds malware-y, but it’s not.

I use it to kill Cubase when it won’t close and also when it closes, but leaves its main process behind (which is always for me).

You just find Cubase in the process list, right-click and select “Terminate Tree.”

Plugins and audio drivers seem to always get blamed (via speculation from forum members), but I feel the onus is on Steinberg to fix this.

I’d need a very convincing argument from a Cubase software engineer to explain why it’s not possible.

I’ve never had any other DAW not be able to close and fully remove itself from ram.

Hear hear. In all my computing years I have never experienced another software app that intermittently hangs on exit. Only Cubase, and it’s been an ongoing problem for years. Blaming a plug-in is a cop out. It’s been happening to too many people, across platforms, for too long.

I’m not even sure Steinberg recognise it as a problem, but is sure is.

I had this problem with my MOTU. It was audio device related, as it behaves differently when not using my MOTU. Can you try using on board audio?

Yes, I think this exact same problem was present already on Cubase 2, if I recall correctly.

Actually not even opening any kind of project results the same way. I can just start Cubase 8.0.5, put computer to sleep, resume, try to exit Cubase: not possible, crashed.

Jalcide, I don’t know why Process Hacker does the trick for you, for me it doesn’t (Terminate Tree). It killed the sub-processes but Cubase8.exe remains and can’t be even successfully loaded again as a double. Only reboot helps.

I don’t have MOTU. I have RME HDSPe AIO. Doesn’t help for the problem if I choose to use the Generic Low Latency ASIO driver.

Hmm, bummer. Was worth a try.

Yeah, this issue has happened with every version of every audio interface I’ve ever had (MOTU, Focusrite, M-Audio and others).

If it’s somehow related to audio drivers I bet it’s a side-effect and not a root cause.

It will be my strong speculation that this is a Cubase issue until someone at Steinberg explains why it’s not.

I guess if the problem disappears for us all, in some future version of Cubase, we’ll have our answer.

Hanging on exit isn’t a showstopper, but sure erodes confidence in the application being “Pro.”

As someone who has lost hard-drives many times, any time something hangs with potential write buffers or files left open, it’s cringe-worthy to have to end processes forcibly, shutdown or even cold restart.

You’re always left wondering if the project will load properly next time and without any corrupt prefs, or worse.

It happens across platforms, regardless of audio interfaces used or plug-ins owned and has been and ongoing problem for many years. Some people get it a lot, some less often and others barely ever. When you think about it the only common factor in all of this is the dongle. Just saying.

Does Cubase 8 have the Steinberg Hub like Cubase 7 does? Because ever since Steinberg reported that Microsoft-related problem with Steinberg Hub, I crashed when exiting 32-bit or 64-bit Cubase 7.5 if I have that feature enabled. If I disable Steinberg Hub in Cubase preferences, the crash goes away.

Even happened to me last week when I had to trash my Cubase preferences folder for an unrelated reason. Cubase defaulted to factory settings and kept crashing on me at exit until I remembered to turn the hub off.

It’s not a crash it’s a hang and if you wait it out Cubase will eventually close. At least that’s the issue I’m talking about. And it’s been going on for much longer than the Hub came into play.

For me I never used to get the issue (7) but after latest win 81 install I am getting a shut down issue.

I am thinking that it is possibly related to a Service being required but isnt available???

For me, the Steinberg Hub didn’t have an effect. I disabled it, no effect.

I agree hang is a better word than crash.

It doesn’t matter how long I wait. Minutes or hours, it stays hanged. I do remember that on some situations on some versions prior to 8, waiting for a REALLY long time did eventually result in a full exit. That was after waiting for perhaps 1 hour or so.

The exit problem in Cubase wears many faces:

a) crashes on exit, then closes.
b) crashes on exit, never closes.
c) doesn’t crash, but never closes.
d) doesn’t crash, but is slow to close (2 to 15 minutes).
e) doesn’t crash, but is really, really slow to close (hours).
f) doesn’t crash, closes, but leaves a “cubase.exe” behind (eating anywhere from 500 meg to 1 gig or RAM). this can also happen in addition to any of the above.

Did I miss one?

It’s been a problem for as long as I can remember.

Right now for me the issue seems to only be “f,” but it’s every time. Part of my process with using Cubase is to simply leave the Process Hacker app shortcut pinned to my taskbar and I just manually “Terminate Tree” after each Cubase close. Or I reboot.

I have been able to get by lately without rebooting, by terminating the cubase.exe process, for maybe 3 sessions, after which Cubase becomes noticeably less stable and I’ll just reboot.

For me it’s been quite rare since CP8 but when it does happen Cubase will usually close after about 3- 4 minutes

Does anyone know, or can find out if Cubase makes a dongle call on exit? That this issue occurs across platforms makes me wonder if there’s a single common factor involved. Different platform with a whole host of machines with different sound cards and different plug-in. Same or similar issue. Same dongle for all. Could have nothing to do with the dongle but it appears to have a certain logic.

Have you tried adjusting your power schemes? If you are using a USB interface, you should set your USB devices to never sleep in your power scheme. Do the following (assuming you’re on W7):

Control Panel - Power Options

  • Select ‘High Performance’
  • Click ‘change plan settings’
  • Click ‘change advanced power settings’
  • Expand ‘USB settings’
  • Expand ‘USB selective suspend setting’
  • Change setting from ‘enabled’ to ‘disabled’

Maybe this will help you, good luck.

It seems unlikely because the eLic, iLok, Waves and Plugin Alliance dongles tend to have their own alerts that popup when they’re not happy. Or, you get a Windows / OS X error about the USB.

Also, because, by definition, they didn’t balk on the most critical use-case: entry to the system.

Also, of the times the USB has choked and therefore caused dongles to balk, I’ve only noticed it on “entry,” never on exit.