Cubase Artist 11- No sound from Halionsonic

New installation of Cubase artist 11 (upgrade from Elements 10.5)
1 Start new empty project
2 Create instrument track for Halionsonis SE, this loads. Add sound in slot 1. I can see midi activity from the keyboard in the bottom bar of Cubase. I can see midi activity in Halionsonic and it is going to slot 1.
3. In the inspector change instrument to retrologue. This works
4. Change the instrument back to Halionsonic, allocate sound to slot 1. Halionsonic now works.

Any ideas if this is a bug or am I doing something wrong. I’ve used elements for many years and never seen this before.

Method 2
1 Add instrument track allocated to Retrlogue - this works straight away.
2, Use inspector to change instrument to Halionsonic, allocate sound to slot 1 This works straight away.


Hi and welcome to the forum,

Where is the issue, please?

When I create an instrument track and use Halionsonic I don’t get audio from it. I allocate a patch e.g. Piano to slot 1. I can see midi data going to Halionsonic and to slot 1 but nothing gets to the track

I also have Elements 10.5 and it works fine there but not in Artist 11.

Other instruments e.g. Retrologue are working fine.

If I click the ‘reset midi’ button on Halionsonic it works. Or if I change the track to a different instrument and back to Halionsonic it usually works.

Often the halionsonic will lose the setting during a project and stop working.

If I have multiple instrument tracks based on different instances of Halionsonic they all have the same problem.


Could you try to increase your Audio Device’s Buffer Size, please?

I went to studio>studio set up >audio system> Yamaha Steinberg USB ASIO
I hope that’s the right place.
Clicked on control panel
(I have tried uploading image)

Tried every size up to 2048 samples
This did not help. I still have to reset midi

I have also tried to include an image to show the midi reset option I press.


I see, you mean the MIDI Reset in HALion Sonic SE, not in Cubase…

Could you try to trash HALion Sonic SE preferences by deleting the preferences folder, please?

HALion Sonic SE Preferences folders are:
Mac: ~/Library/Preferences/HALion Sonic SE
Win: %appData% Steinberg/HALion Sonic SE_64

1 Like

That made no difference
I moved the entire folder onto another drive. These are the files that were moved

The entire Halionsonic SE_64 was removed from the C drive

I then restarted Cubase and the folder ws recreated with these contents

There is also a folder for the Standalone version but I did not change these

The behaviour of Halionsonic SE has not changed.


Could you try to send the Reset All MIDI Controllers MIDI Message at the beginning of the MIDI Track, please?

I went to the menu midi>reset . This worked on all selected tracks, but they lost connection if I clicked away and then re-selected the track. This is just the same behaviour as before when I was re-setting the midi in the instrument.

I am no expert in MIDI. was there meant to be another way of resetting all midi controllers?

However, did discover that I have a virtual midi port running called loop midi to connect a Stream Deck controller to cubase. Turning that off cures the Cubase problem (but clearly stops the Stream deck working).

It’s strange that it only affects the Halionsonic instrument and not Prologue or Retrologue.

Does this information help?


Yes. Send MIDI Controller 121 to Reset all Controllers, please. You can find the list of the MIDI Controllers here.

Sorry. Don’t know how to do that. I’m away for a few days. Back on Thursday.

Looks like I have solved it.
For some reason the connections in the midi setup in cubase pointing to the virtual midi ports had changed.
The input and output ports were placed in both the inputs and outputs and were both active. So there was some strange midi loop happening. Tried to make one of each inactive. It would not change, so I went to bang my head on the wall, (get a coffee) and when I came back they had changed and is now working correctly.

1 Like