Cubase artist 6 won't install osx

I have the latest version of OSX (10.10.1) installed. When I use the cd to try to install, it won’t let me and tells me I need OSX 10.5.0 or higher… which is far below what I have.