Cubase Artist 6 won't open....

Hi - I’ve got cubase artis 6 running on a Dell Inspiron I5 running windows 7. I tried to open it today and it hung at the initialising eLC stage. I have downloaded to latest updates from the eLC site, and also now downloaded 6.0.5 for cubase, but I can’t seem to get it open at all!! Any help would be much appreciated!!

I’ve got the exact same problem. Im on a HP pavillion dm4 running windows 7. It was fine before, even the first time I opened it as 6.0.5 I believe


please re-connect the USB eLicenser to the USB port and try to start Cubase again.



Yeah, I’ve tried that many times, I’ve restarted, and tried it yesterday and today. It still freezes on that loading image with initializing eLC in the bottom

Thanks Chris - but I’ve tried that several times as well as full reinstall of elicencer and cubase but nothing is working. Georg in the technical support team is currently trying to resolve this for me… maybe I shouldn’t, but I do take a little comfort in the fact that it isn’t only me that this is affecting.

Yeah, please post and let me know if you find a solution. Have you tried completely uninstalling cubase, then reinstalling it? If I do that will I loose anything?

I’ve still not had a solution - have you had any luck yet? I’ve uninstalled and reinstalled everything. Support team are still working on it.

Hi - thought you might like to know - I’ve just got a solution to this!!

Steinberg Support guided me to this link

Step 2, initialising preferences has worked for me! Thank goodness - hopefully you’ll also have the same success.

Good luck


Yes! It worked for me. Thank you very much