Cubase Artist 8 stuttering and not using all ram?

I am running Cubase Artist 8, with some pretty big projects (lots of samples and plugins). The past couple months the bigger projects have been stuttering a TON, to the point that I couldn’t even listen to the song. Earlier I had 16gb of ram, and cubase didn’t use all of it. Recently I upgraded to 32gb of ram, and it is still only using 30% with the same amount of stuttering. I have a really good Xeon CPU, so I am pretty sure that it isn’t the issue. My buffer size is at the largest, even though with my specs I should be able to run the lowest with no issues. I have searched all over the internet for a fix, and haven’t found any. Is there any way to allocate more ram/fix this stuttering?


Hi and welcome,

Is your Buffer Size set to maximum?


He says his buffer is set to maximum.

I have the same problem, even with my buffer set to maximum.

Do you know of a setting either within Cubase or in Windows or the BIOS, which will help Cubase use all of the available RAM please?

It would be a great help to be able to use all of the pc’s power.

I also have the situation that it doesn’t use all of the CPU’s power.

I have read that Windows 10 is limited to 32 processes but this should not affect my CPU (Intel Core i7 3930K 3.20GHz Socket 2011 12MB Cache)

I would be very grateful for any insights.

All the best


Still have this issue. Here are my specs:

32 GB Ram
Windows 10 Pro
Intel Xeon CPU E3-1286 v3
200+ gb free space
Nvidia Geforce GTX 1050 Ti
Cubase Artist 8

The project is unplayable. Thinking about switching to a new DAW.
There is stuttering multiple times every second, and when I record, it usually stops playing and gives me the message that an audio dropout has been detected.