Cubase audio dropout while recording

Hello there,
Since my last pc kind off died I’ve switched over to my laptop for making music: i5-9300H, GTX 1660ti and 16 GB of ram, way more powerful than my last pc.
But as soon as I start recording or even playing back my recordings, the audio cracks and pops and drops out so frequently that I can’t really do any work on it. I didn’t have problems with my old pc but here as soon as I load Kontakt drums or something else and try to record guitar. The audio either cracks or it flat out drops out.
Audio interface is Steinberg UR12, Buffer size is 512 Samples and the sample rate is 44.1 kHz. I’ve tried switching the sample rate and buffer size but that didn’t change anything, if anything it made it worse. I’ve been also playing with multi processing, ASIO guard, Processing precision and power scheme and turning them on and off but its still not in workable condition. I’ve also reinstalled the drivers for the audio interface but it still doesn’t work.
Has anyone had this kind of problem before and if you had how did you fix it? I have been racking my head for a few weeks and searching the forums but have no clue how to fix it. :face_with_monocle:

often the best tips for working on a laptop is to disable network, wifi, and Bluetooth

I would recommend running Latency Mon if that doesn’t help.

Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks

some laptops have horrible audio performance, the only laptops I found decent are Dell and Razer… but then again I never bought a laptop for audio production use.

This is what it says if it helps somehow. The laptop I’m using is a Lenovo Legion and is just a temporary solution before I build a new pc but I didn’t expect it to be that bad as my friend uses a much lower spec laptop and it doesn’t have any audio issues.
The bar here is always peaked, even though my CPU and GPU are at most at 10-20% usage.

is this with wifi etc disabled? I would also disable the internal soundcard and try again. and also there is something going on with the graphics drivers it seems.

Wifi, bluetooth, internal soundcard are all off and it seems that it doesn’t make any difference. I’ve tried updating the graphic drivers but it didn’t help

did you tried all available USB ports?

I’ve tried all of the ports, plus a usb-c to usb-a hub and it didn’t seem to affect the performance