Cubase Audio Issue and PC Upgrade

“You’ll see a lot of “NVIDIA Container” processes running on your PC. This program, named nvcontainer.exe, appears to be responsible for running and containing other NVIDIA processes. In other words, NVIDIA Container isn’t doing much itself. It’s just running other NVIDIA tasks.”
It does stuff like supports the tray icon and notifications, automatic updates, provides telemetry, network game streaming, Shadow Play helper (open GForce Experience by hotkey) and a bunch of other things that you in no way need for audio production. These services can take up to 10% of your CPU cycles in some cases.

Yes. Go to the Drivers tab and click the “Highest Execution” header if needed to sort highest execution time first. Should look like this


Now you need the ones mine is displaying at the top: the NTkernel, NVIDIA Kernel, DirectX, Storage port, etc. Most things that are Microsoft you don’t want to touch. You are on the right track with Googling the service, and I usually Google “Is it safe to disable XXX”. Then try disabling the service if you’re comfortable with the info you found. I then do the same thing, but sorting on Total Execution. Also, I would probably only run for as long as you usually are working in Cubase, and actually it’s good to go jiggle the mouse or hit the shift key or something every 15 mins so any “Unattended” tasks don’t kick in and skew the results.
If this is new to you, I would start with only disabling one thing at a time, and write it down or take a screen cap, and rebooting and try a few common tasks and make sure everything is OK before tackling any others. The Stats tab, also gives a good overview of the analysis and is worth a peek.
The help page does a pretty good job of explaing how to use it. Hit the “?” icon or go here

Also, check the Processes tab and sort the “Hard Pagefaults” column. This has to do with how Windows handles using the virtual memory in your system. This is also a big issue. Things you can do to decrease page faults are disabling programs that cause them if possible (or at least while you’re working in Cubase), decreasing the size of your pagefile (virtual RAM), and increasing the size of RAM. It also helps to have your pagefile located on a very fast drive like an SSD or preferably an NVMe drive.
The Latency Monitor help files do a good job of explaining things:

You say recently this started to happen. Did anything change for this to start? Sometimes a clean windows install can clear out a lot of problems. Let it load drivers itself and go through the list of tweaks for power settings etc and run latency mon again. I have three PCs in my house. One is an old i7 960 with 18gig ram (this had Triples) and about 10 year old if not more. another is an old server with a xenon 3.3ghz with 16gig ram and a i9 9900k with 32gig ram. The i7 has an amd video card. The xenon a radio 1030 and the i9 I use the onboard graphics. All three work great down to 64 samples for buffers. The i9 can run more plugins and I use a m.2 for quick sample load but apart from that there isn’t a huge difference


This is what I got.

In the meantime I updated all the drivers that were out of date but to no success

I had similar issues with a worse PC (8Gb RAM) and it was Cubase’s fault (CPU spikes in 10.5.30 - #2 by SF_Green).
I’m now running Studio One Artist and Ableton Live Standard successfully. I would really prefer to use Cubase, but those sound pops are a show stopper. I hope they are able to fix this in future updates.

AVAST antivirus, is the first thing I would remove.

1 Like

Agreed with that. Also try suspending updates and see if that makes a difference. I would still be tempted to re-install win 10 as that will clean up a lot of rubbish

One of the things the Kernal Mode Driver Framework ,KMDF, is involved in is Power Management. If you have already tried using the Stienberg power management options in the preferences, then try using the windows High Performance setting, and if your version of Windows has a High Performance specifically for your CPU (mine has “High Performance for AMD Ryzen”), try that one. Also, go through the advanced settings and make sure everything is set to 100%, and never off.
Also, go to System > Manage > Device Manager and expand all your USB entries, right click on each, go to the Properties > Power Management tab and disable “Allow the computer to turn this device off to save power”
Then retest with Latency Monitor and see if your KMDF value has gone down.

It does worry me that it may be something else. I know with a clean install on all three of my computers without any power tweaks I passed the latency mon test and they all worked without a glitch. I just did the other tweaks afterwards to make sure.

Disabled AVAST
Disabled "Allow the computer to turn this device off to save power” on all USB entries
Tried the Windows’ High Performance settings
Updates are paused

Not much of an improvement

I reinstalled Windows 2 months ago and the problem was present both before and after the reinstallation, so I don’t believe that will help

In the meantime though I found something interesting. In this particular project where the cracks and pops appear extensively I have an instance of Superior Drummer 3 and 2 instances of Waves Bass Fingers. I opened a project from yesterday where I’ve frozen the Superior Drummer tracks as well as the two Bass Fingers tracks. The project runs fine, no cracks or pops with an average load of about 80-90%. I decide to unfreeze the Superior Drummer and Bass Fingers tracks just to see what will happen and as expected brutal cracks and pops appear basically making any listening experience impossible and the average load is slamming in the red.
But here is where the interesting bit happens - I close the project and open it again without saving. Superior Drummer and Bass Fingers tracks are again frozen just like in the beginning when it played fine. But this time even with these VSTs frozen the cracks and pop are again present and unbearable making me even more confused than before…

I bought a new beefy Dell Precision for music and suffered thru the same issues you are, tho the names of some of the culprits (files, processes, etc.) were different. The worst was ACPI.SYS—related to power management, as I understand it. I got to a workable state that involves a large buffer size, ok for me since I don’t do much recording. These things helped:

Glitch Free - Cantabile - Software for Performing Musicians. - the most extensive audio tuning guide I’ve found short of hacks that are too out there for me; and

https://bitsum.com/ - Process Lasso, a utility that allowed me to set processor priorities for Cubase so that it wasn’t fighting with ACPI for CPU. This brought the DPC delays down.

I don’t claim to understand this stuff so you experts out there, please excuse me if I’m imprecise in what I’ve said here. I’m just sharing what worked for me.
KHARMA

I use SD3 and generally have around 3 instances of it open without any performance hits. I think there is a problem though if you use grid editor in SD3. I don’t use midi inside SD3 as I am used to Cubase drum editor which I have used for years.

Do you have an onboard graphics card? If so have you tried removing the nvidia card and using the onboard with the driver windows loads? Doing that would rule it in or out.

So, if you are using MIDI, you should change you Audio Priority setting to normal. You said in your first post you have it set to Boost:
Audio priority is set at Boost

This is a very misleading setting. I finally read the manual on this one. You should only set it to Boost if your Project contains ONLY Audio and no MIDI. Otherwise you want the Normal setting to give Audio and MIDI equal priority. That may be why when you engage SD3 and Bass Fingers you get the issues.

From the manual:
Audio Priority (Windows only)
This setting should be set to Normal if you work with audio and MIDI. If you do not use MIDI at all, you can set this to Boost.

Cuabse 11: Setting Up Audio VST System

Good point

I have both a Focusrite Scarlett 2i4 and an Apollo Firewire Quad 2. Both give similar results. On the Apollo I seem to be getting audio drop outs even when playing a simple project with no plugins which I guess is a problem with the Apollo itself because the Focusrite doesn’t do that.

I don’t use the grid editor in SD3. I use the Cubase drum editor.

I don’t have an onboard GPU.

I tried going back to Normal Audio Priority. Can’t say there was much of an improvement.

I opened the problematic project today again and unfroze everything. It actually ran fine for some time. Then I opened a plugin to try and do some mixing and it started popping and crackling. Closed the project and opened it again - Now it’s crackling even with everything frozen.

I will try the BitSum and audio tuning guide suggested my KHARMA probably tomorrow and will write back. In the meantime I’m still open to more suggestions :slight_smile:

Giving a little bit of an update:

Tried BitSum to give Cubase more priority but it was already on High, so no changes there
Fried up a 100 GB on the SSD because someone suggested that the lack of space could be an issue, but nothing changed.
Tried everything here Fix Wdf01000.sys Failed BSOD with 7 Expert Tips but no difference
I updated my BIOS driver because somehow I’ve missed that one but no improvements.
Ran LatencyMon and still wdf01000 and dxgkrnl.exe had the highest Total Execution time.
Changed the BIOS Drive setting from ATA Mode to AHCI Mode, nothing changed.

Opened a different project last night. Pressed play and got the following BSOD :)))))
Started the PC again, opened the same project, pressed play and another BSOD followed.

I think it was because the buffer size of the Apollo was set to 32, because thats what it defaults to. Made it 2048 and no BSOD this time. Tried it with 32 this morning again but couldn’t get the BSOD

Haven’t had the time to try everything in Glitch Free - Cantabile - Software for Performing Musicians but will do these days. Not having much hope at this point though

Not sure what to do anymore. It feel like everything is getting worse rather than better…

so you did the “DISM Restore health” and “sfc /scannow”? Did both of those return no errors found?

Kind of a very late reply but decided to write it anyway

Tried the “Glitch Free - Cantabile - Software for Performing Musicians” but can’t say it did a lot. Maybe for someone else it could help though

Ended up upgrading the PC with an i9-10850 and 64 GB of RAM.

No more problems present. Projects work lightning fast. Even the problematic project runs smoothly without any tracks being frozen(not that I need that project anymore but at least it’s good to know :D)

I guess it was down to hardware after all.

Thank you all for the replies and for the help!

Closing the topic :slight_smile:

1 Like

Glad you found a solution, even if it was a bit costly. Still, a system upgrade is good in the long run.