Cubase automation not recording all steps - bug or not?

So I automated EQ frequency for each note. When recording I made 8 steps (between 1500 and 900Hz). using ProQ3.

Cubase only recorded two points (see picture, red lines indicates steps I moved the frequency, green circles show the only recorded points I got).

This happens too often and is quite a bit frustrating. Anything I need to do to make Cubase record continuously?

Hi,

In the Automation Panel click to the Settings tab and double-check the Reduction Level parameter, please.

Thank you, that helped.