Cubase cant find Korg products / Midi Port issues

Hi guys,

I just bought a Korg PadKontrol and i’m experiencing ridiculously annoying issues getting Cubase to see it. What’s weird is that when i plugged it in for the first time it worked fine in cubase, it’s only when i tried using the Librarian assistant to map the pads to Geist (but it didn’t recognise a Midi connection with PK) so i installed the korg website drivers as well and then everything just stopped working.

On top of that my Microkey (also Korg) isn’t recognised in Cubase either but everything else (casio keyboard/saffire premp/serato scratch/external hd’s) work perfectly.

I read that it is to do with them having to be in Midi ports 1-10, but i just deleted my faderport which was on 10 and put PK there and it still doesn’t work. Im abit weary of deleting the 1-9 ports as i can’t tell what they are (apart from an Nvidia one)

I have tried most suggested fixes. Uninstalled all Korg related drivers and reg keys, then started again but still Cubase just doesn’t see it (or the Microkey) anymore.

The troubleshooting has made me realise i have quite a few shadow copies of midi ports (for example ‘usb device’ takes up about 6 ports) but all my other audio equipment (casio/Rane/Saffre) are all on the 17/18+ midi ports and they work fine.

Anyone know of any utilities out there that can clean up the midi ports? Or has anyone got any other ideas on how to fix this (without reinstalling windows :frowning: )


Did you try the Program Files (x86)\KORG\KORG USB-MIDI Driver\UnInstDrv64.exe ?
Check out the Options to untick “Delete Korg Devices Only”.

Hiya, yep i did that to remove my faderport and the korg drivers. I’ve got about 4 ‘USB Audio Device’ entries which take up midi ports 4-8 and am wondering if i could delete them. Im guessing they are from old external hard drives but im unsure.

Ok fixed it by deleting midi 1 and 2 ports.