Cubase can't see 3rd party plug-ins - please help

The core issue is I am trying to open the the Novation UltraNova Editor in Cubase 5, with no success.

Thank you.

Point to the location of the .dll via Devices-Plugin info-VST2.x Plugin paths.

I did that, and it did not work…

Did you re-start Cubase? Is it Blacklisted?

Yes, I have tried restarting Cubase and restarting the PC. Cubase is not blacklisted.

Not Cubase, the plug.

I see. thanks for your help. please explain blacklisted? I dont see the plug-in anywhere.

This problem has now been solved and the UltraNova editor works.
here was the tricky part. Installing UltraNova installs .dll files in two different folders in the programs directory.
this one, most obvious:
F:\Program Files\Novation
the editor is not one of the two.dlls that live here.
and this one:
F:\Program Files\VSTPlugIns
open this further:
F:\Program Files\VSTPlugIns\Novation and the editor is there
UltraNova Editor.dll

then pointing cubase to this folder and restarting cubase, cubase sees it and opens it as a VST instrument.

thanks Mashed for your help. everyone enjoy Cubase!