Cubase change my clock source at upstart

I just migrated to MAC and installed Cubase 10.5 on an iMac.
I hadnt this problem with my Windows PC, but now when I open an empty project Cubase sometimes force my Audio Interface Apollo X8 to change clock source from Internal to SPDIF, worldclock or ADAT randomly.
This is a bit irritating and I cant find out what makes it do this?

  1. Double check your clock source setting in the Apollo Console software.
  2. Cubase shouldn’t change anything unless that clock source setting is saved to that Project in the Studio/Studio Setup/VST AudioSystem.
  3. Are you sure you don’t have anything sending CLOCK signal to the Apollo?