Cubase changing midi tracks when imported

How do I get cubase 12 projects to match the tempo of imported midi files instead of quantizing imported midi tracks. Basically, I want to import midi tracks and have the midi tracks be unchanged from the orignal, and if possible have cubase match the tempo of the original midi file. I have done multiple projects on my Android with Caustic which exports midi files as cakewalk midi files and a couple projects I swing the tempo but Caustic doesn’t give you exact swing tempo numbers. When I import these files into other platforms they are fine, but Cubase automatically quantizes everything so it ends up losing the swing. How do I geg around this?

Hi,

Every MIDI file must contain a Tempo information. There is no way to have a MIDI file without a tempo.

There are 2 options, while importing MIDI File (to already existing project):

  • Import the Tempo, so you will get the original tampons (speed) for all tracks.
  • Ignore the tempo, so you will get the tempo (speed) of the current project.
1 Like