Cubase confuses a pair of Generic Remotes ?

I have two Korg Nanopad2 controllers.

One has been programmed to transmit CC#'s on midi ch 15, the other to transmit same CC#s on ch16. This is done from the Korg PC editor software and written to each hardware unit via USB.

  1. Create 2 GR’s in Cubase,
  2. For GR 1, map midi device ch 15 in the MIDI Input pulldown. Apply changes
  3. Do same for GR 2. Apply changes
  4. Switch between them in the left side menu. Cubase re-assigns both GRs to the same device. i.e. Cubase overrides the device I tell it to use at the top of its GR screen. Not cool…

Working studio…any help is appreciated, thanks


Do you mean the same MIDI Input port is assigned to both GR? Or the GR itself changes…? Have you tried to Export the GR before you switch?

[first msg edited for clarity/procedure]

Hi Martin
The former–the same MIDI Input port is assigned to both GR. Yes exporting nicely saves my settings but doesn’t help the issue. Cubase 10.0.20 Can you replicate with 2 Korg Nanopad2 or similar devices ?

In addition, Cubase does not see MIDI activity from the auto-disconnected controller.

Both devices have individual USB cables plugged directly in to motherboard USB slots. Have also tried plugging both into a USB hub, also different cables, same issue, Cubase replaces my selection and the 2nd device goes to Inactive state.

Hi Martin, I’ve provided some more clues above, do you need any more info from me to duplicate/troubleshoot this ? I need to be able to use both Nanopads. TIA


Unfortunately I don’t have 2 same devices I could test with. I’m thinking, how to emulate it, but so far I haven’t come to any idea.

Could you try to use any 3rd party application (for example MIDI-OX) as a MIDI Monitor? Can this application distinguish 2 different MIDI Ports/devices?

Is there a Device ID parameter available in the Korg Editor? Maybe that can help.

Or, Bome Midi Translator can see them as different devices, and I think that is due to how Bome deals internally with midi ports naming. It will create an alias name automatically when it see identical names from the devices. Then, you can route it out of B.M.T. via its virtual midi port feature.

I don’t see any Device ID parameter capability in the Korg editor; just a midi channel (I have the pads on one device set to channel 15, and the other to 16.) In Korg pref’s you can however select the different MIDI in/out device for communication, one at a time.

Bome sees both devices on the MIDI In & Out menus and the device it hears changes as I select either of the two “nanoPAD2” entries in the MIDI In menu. Both devices in Bome are called “nanoPAD2” (exact same spelling for each) under the Midi In & Out menus (this goes for MIDI OX also–same spelling). I don’t see any alias created, but I’m also unfamiliar with Bome. In MIDI OX, port shows “–” when MIDI is received from device.

Tapping one pad of each controller, MIDI OX shows different “IN” (5 for one device, 6 for the other) but “PORT” is “–” for both (see attached image)

Thanks for the troubleshooting, this is a new one for me. Please lmk what this all means, and my next steps, if you could.

Have you checked how they are listed in Studio Setup>MIDI Port Setup?


in your screenshot, it can be seen, that Midi-Ox separates the two devices into two port ID 5 and 6.

if you are already using Midi-Ox, a good basis to a possible solution is already there. You could try to route the two Midi-Devices straight (without transformations) to two separate virtual midi out ports.

Before doing that, install a virtual midi port software like LoopBe or Springbeats. It creates numbered (!) virtual midi ports. Springbeats (up to 8 ports) and LoopBe1 (1 port) are free. There is also LoopBe30, which is not for free.

In Midi-Ox it just requires to select the two affected inputs and two of the new (virtual) midi output ports. Then in the router window of Midi-Ox draw a line between each of the pairs of an InPort and an OutPort. Those two (virtual) midi ports are to be used one each as midi input for the two Generic Remotes.

Then Cubase can clearly separate between the two devices which had the same names before. (Sounds to me too, as if this naming issue is the problem within Cubase.)

LG, Juergi

Thank you guys very much for the help. I am getting closer, but now Cubase does not even hear midi from either device.

See attached for how I have set things up, please lmk if anything is not clear.
Also see attachments in the next post.

Cubase MIDI setup. Cubase does not hear either device at this point.

Ok, my bad, the 2 ports in LoopBe need to be UNCHECKED in order to pass midi. Now Cubase hears both devices, which is progress. I will report back!

Success! All of the instructions above were super helpful, and now I feel more confident mapping midi in my studio. Big thanks guys! :facepunch:t4:

Note- Because both devices have the same name in all apps, it was confusing and took several tries to identify them properly in both MidiOx and Cubase. Start by setting up MidiOx according to attached screenshot, so you can see the activity happening on each port. Rename your controllers to unique names. Map accordingly with virtual patch cables. Save your settings. Then set up Cubase Midi Devices.

I also found that 1. it is necessary to restart Cubase after making any changes in MidiOx. 2. unplugging a pad controller would require a Windows restart before the apps could see it again.

Hope this helps someone else too. Cheers

UPDATE - MidiOx is useless* because it loses it’s settings upon restart, even if you save them. The principles in this thread work, but we need another program to do the mapping and auto-start with Windows. I will try Bome next.
*for identically named devices i.e. this scenario