Cubase CPU utilization

I’m currently rendering a lot of projects with a bunch of plugins with some serious oversampling going on. 3 minutes song takes about 7.5-8 minutes to render on the overclocked i9-10850K.

Decided to look into the CPU utilization and it’s never been more that 20% and just a couple of threads. My PC fans are dead silent while RENDERING. This isn’t right.


WHY THO

I really want to find out what is the bottleneck here, as time is a precious resource and this kind of rendering eats a lot of it.

How can it be improved?
Is there something in the works for improving the current CPU utilization?
Why does every 3d or video rendering software utilizes CPU to the max and Cubase does what it does?

Hi @sergeyotro ,

  • which buffer size are you using? → the smaller the buffers, the longer the export duration
  • is there any complex routing in the project which is not visible on the screenshot? Complexity (better: dependency) in the routing can lead to long export durations when parallel processing is impossible
  • which power scheme are you deploying (when in doubt, enable the Steinberg Audio Power Scheme in Studio setup)?

Could we have a look into your project, if the described steps don’t help? The load distribution looks strange, indeed. The stripped project without files would be enough.
Cheers
Christina

1 Like

Hi @Chriss, thanks for tuning in.

I’m using 2048 @ 48k buffer, the maximum my Audient iD14 MK1 offers at that sample rate.

Now, that you’ve mentioned routing, I’m thinking this could be an issue. All tracks go to the “mix” group channel, it goes to the “master” one and then it goes to the “stereo out”. BUT there’s a lot of sends between the channels going on, though.

Here’s the screenshot of the mixer window with all sections opened.

Mixer Screenshot

Power scheme is set to High Performance, with all the performance settings bumped to the max.
I’m also using an overcloking via Asus z490e bios, all cores set to 4.9GHz & cache to 4.7GHz, all the time.

Power Scheme

The export is set to multiple tracks, the mix group channel, stereo out and all the individual tracks.

Export window

Here’s the project file without the audio files: [Lazy Waves]-77bpm-Am-2021-03-12.zip (3.3 MB)

Hope this could help to pinpoint the issue here.

Thanks,
Sergey