Cubase crashing When adding tracks (not vst issue)

Hey guys, newbie to the forum but long time cubase user. :slight_smile:
Signing up and annoying the forum is a last resort as i work with computers so usually a quick search and some elbow grease i can resolve issues myself, but this one is wayyy out of my league.

Well 4 days ago i received my brand new out of the box cubase 8.5 PRO, and after 4 days of nonstop banging my head against a wall i have to throw in the towel because every time i fix an issue there is a brand new one right behind it. :cry:

It all started with the control centre refusing to download the licence, and i fixed that.
Cubase was crashing on initialisation and i fixed that.
Then cubase crashed trying to load its own VST (Retrologue), i fixed that.
Cubase then decided to crash upon the steinberg hub loading. I fixed that.
Cubase was crashing upon creating an empty project. I fixed that (i think).
cubase crashing after about 20 seconds ( it seems to have stopped that but i cant be positive) :laughing: :laughing:

And now finally when cubase is open and seems to be functioning (yayy) but wait… any attempt at inserting an instrument track/midi/chord track or loading any of the standard cubase vst instruments etc it crashes.

I cant begin to figure this out after hours of searching most of the fixes are VST problems and i am pretty sure that these issues are not the VST.

I am running windows 10.
Clean install with just the operating system (i thought resetting might fix this) Fully updated to the latest updates.
No third party plugins, no preferences (all hidden) nothing else. This is just a clean computer trying to run a clean install of Cubase 8.5 pro (i tried reinstalling multiple times with and without cubase updates)
The newest ECC installed and maintenance run.

i have stripped everything down to the basics, just the computer and cubase. i am trying one last hail Mary which is to download the cubase pro from my steinberg and not use the Disks to install it, but i’m pretty sure this wont work.

So while waiting for the download i dragged myself over here hoping that someone out there will be a hero and have some sort of solution.

I really really really look forward to using cubase again, and i’ve been waiting almost a week from the date i bought it, between the delivery and the issues. I apologise for any headaches that may result from this post. :laughing: :laughing:


Install the latest Cubase 8.5.20 update please. If it doesn’t help, try to trash Cubase Preferences, please.

Hey Martin, Thanks for the reply but fortunately In the time it took the moderaters to approve my post (2 days as i posted on a Saturday) i have resolved all issues. Sorry for any inconvenience :slight_smile:

Thanks Again


I’m glad you solved it.

Great to hear you sorted it out. What was the issue that caused the problem?