Cubase does not load session drummer properly

It seems as though every windows update made session drummer plug in disappear. I had this in Sonar Platinum, and Cakewalk by Bandlab. Recently, as a new cubase 11 user, I loaded session drummer as an instrument track. Everything appeared to be fine, but when I clicked on show instrument, nothing was there. I used the same solution that solved the cakewalk problem
Windows updates sometimes overwrites, or slams (?) a visual C++ 2012 Redistrubutable (x64).
I ran that exe and Session Drummer worked perfectly again.
Here is the name of the Redistrubuatable:
Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030
If you can’t find it on Microsoft site anymore and have this problem, I’d be happy to send you the file. In cakewalk, you couldn’t even see Session Drummer to load it. In Cubase, it loaded the instrument track, but going to select kits, nothing appeared.
I’m thinking of checking to see if some of my other older plugins are now being picked up in Cubase after running the Redistributable exe file.