Cubase Elements 11.0.20 no longer detects steinberg cl2

Hi, my version of cubase elements 11 no longer detects the steinberg usb audio interface Cl2. I restarted my system a bunch of times, and the program as well. When I test the Cl2 in control panel in windows, it plays a sound, so it seems functional. In Cubase the audio connections dialog doesn’t list steinberg usb line like it used to. I tried reinstalling the Cl2 driver, but it was already installed according to the installer. I don’t know what to do, currently I can’t use my software. Any help or insight is much appreciated.

Hi. Are you on Windows or Mac?
If Windows, I would uninstall the driver and unplug the Cl2, reboot, then reinstall the driver, plugging in the Cl2 when it tells you (or after you complete the installation, if it doesn’t).

Hi, thanks for the reply. I am on Windows. I followed your direction exactly, but Cubase still doesn’t list the usb driver for the Cl2 in audio inputs or outputs. The only thing that it lists is the generic low latency asio driver, which when selected gives me the option of VoiceMeeter for input, and NVidia high definition for output.

Well, try re-installing Cubase then. After that, you should just put in a support ticket with Steinberg. Sorry I can’t offer more help than that.

No prob, thanks for the help.

Did you start Cubase without activated CL2? Every time i forgot to power on my audio interface Cubase wasn’t able to detect it. Even after restarting Cubase nor Windows.

Safe mode is helpful. Start Cubase while holding CTRL + SHIFT + ALT, then reset the preferences. After that your audio interface may reappear. Make sure to save your custom settings first.

Here is the solution from support that worked in case it helps anyone else:

Hi Chris,

Let’s try resetting Cubase.

  1. Quit all running Applications including Cubase.
  2. Hover over or right-click the start tile (lower-left corner by default) and right-click and choose file explorer
  3. Navigate to C: > Users >“Your Folder” > AppData* > Roaming > Steinberg
  4. Move any folder with Cubase in the name to the desktop leaving no Cubase titled folders behind.
  5. Launch Cubase and test again. You know if the process worked if you are asked to register again(Cubase Nuendo and Sequel only)

We can undo these changes if necessary by repeating the steps but moving the folders in step 4 back to their original locations replacing any new ones that were created.

  • AppData is hidden to show follow this.
  1. In the file explorer ribbon click on the View Tab
  2. Put a check in the hidden items box.
1 Like