Cubase Elements 11 unable to locate Halion/Groove Agent Samples on Mac

Hi there, Wondering if anyone can help me. I’ve tried installing Cubase elements 11 a couple of times now, each time deleting all trace I can find of the application on my system; preferences, library, etc and each time I try to run some of the templates that rely on halion or groove agent, it just tells me it’s unable to find the samples. The Library Manager is also empty.

I know the sounds are installed as they currently sit as vstsound files under HD/Library/Application Support/Steinberg/Content/(Groove Agent/Halion) but absolutely none of it has been picked up by either application.

Any clue as to what I can do to try and nudge them to do something?

What happens if you double-click on one of the vst content files? Is there some kind of security thing on your Mac that’s getting in the way? (you didn’t say you’re on Mac, but the file path gives it away.)

Ah yes, sorry, Mac!


Weird. so it’s still empty after performing the action but tells me that they’re already registered…

Tried ‘editing search path’ for samples, sending it directly to that folder, didn’t work either…

But I asked you

in the Finder

Ah right, yes, did that and the modal in the image appeared. so it appears to be some kind of thing where the programme is aware they exist but the library programme has no idea how to display it. As an aside, I checked the ContentManager.xml files for both programmes - the both have something similar to this:

        <string name="Path" value="/Library/Application Support/Steinberg/Content/HALion/VST Sound/" wide="true"/>

So even the generated files appear to be pointing in the right place.


One last thing - media bay seems to also have these checked by default. again, absolutely nothing works if I try any of those programmes e.g.

There must be somethign else wrong on your system. None of this faffing about is necessary, so you shold troubleshoot elsewhere.

Personally I would start by making the Library Manger’s default location a folder inside Documents, which your user can see, so presumably so can the SB utils

btw, the Library manger is, totally solid and works perfectly here.

Heh, i’ve moved everything everywhere. TBH looking further into it there seem to be some vstsound files that are apaprnetly meant to come with it that simply aren’t in the list I have. No idea. Still, OTOH i have a billion other drum samples anyway, would just have been nice to have this work without all the faffing about

Just want to be sure – when the files are opened, that is when the Library Manager registers them in the local database.

What if you try and , sorry but, begin to re-create the preset? Does it find the files and load then? If so, then I had the same problem moving between the laptop and the studio. When I re-installed all of the libraries to the default location (not move reinstall). It worked. Of course that took up a lot of space on the C drive, but it worked.

I assume so - double click on the file, library manager says it knows about them already, doesn’t display them though

hmm, it can’t find any samples to try to recreate the preset. all vstsound files greyed out when i try to register the sample.

Where do you see these grayed-out .vstsound files?


I then double click that row and then locate the files…

Is this due to that folder being hidden by default? What OS vers?

Hi,

These files are not hidden on Mac. They sit in the public folder:
SystemDrive/Library/Application Support/Steinberg/Content/Groove Agent/VST Sound

Groove Agent is searching for the *.wav file and these are the *.vstsound files. Are you sure, you load a factory preset?

1 Like

Yup, just selected one of the OOTB presets. And yes, it’s weird it’s asking for a soundfile unless there’s some mapping underneath that is expecting a particular vstsound file to exit.