Cubase Elements 8 freezes on Steinberg hub

Everytime I open Cubase it completely freezes on Steinberg Hub and stops working. I can open projects normally from my project folders but creating a new project/loading one through the hub,or doing generally anything,is impossible. Cubase worked just fine yesterday and now suddenly this. I haven’t applied any changes/updates into my PC. I’m running on 64bit WIndows 10. Anyone else with the same problem? :frowning:


You could disable Steinberg Hub in Preferences, which doesn’t solve it, but at least you can use Cubase.

Thanks,I’ll do that. Hope they’ll come come up with a solution in the near future. :confused:


This is not a known issue. I mean, you are the only one so far, who has this kind of problem a reports it. I believe, if this would be a global issue, it would be already known.

You could also try the Safe Start Mode.

Safe start mode didn’t help,thanks for the tip though. There must be something else going on…something has probably changed in my PC and I just haven’t noticed,can’t come up with a better explanation. :confused:

The Steinberg Hub is connecting to the Internet. It is using Internet Explorer core on Windows. Maybe something in this area has changed.

Yeah,it definitely seems to be network related. I opened a project through the projects folder and tried opening the Hub from there. It never established connection but otherwise worked just fine. Any ideas?


I’m thinking about some firewall or antivirus frictions…

Me too, if your general Internet access is okay try placing the Cubase executable in your AV exclusions list.

Fun thing is that it’s already there. I thought it could be a problem with Avira so I deleted it and tried again,still freezing.

EDIT:Skype and Windows appstore are not working either,they freeze/ctd right on startup. Maybe a bug with W10? This is driving me crazy.

Guys;I was able to solve the problem. After trying numerous solutions I created a new user and everything worked fine using the new one. Something must have gone bad with the old user so I copied my files and deleted it. Thanks for all of you who took time to help me!

Congrats! And thanks for sharing.