Cubase Elements either plays MIDI or real audio

Hello everyone,
I recently installed a Cubase elements trial version, and I am trying to set it up with a project containing both MIDI and audio files;

My soundcard is a Behringer U-Phoria UMC22, and I downloaded the latest ASIO4All drivers; I have a PC with Windows 10.

The story is as follows:

  • Right after the installation I opened a previous project and tried reproducing the MIDI tracks: everything went fine;

  • Then I tried to record some guitar track over it, but no input was detected although I could hear it from the soundcard monitor;
    then I went on Studio-Audio connections an Studio-Studio configuration and realized that (MIDI) sound was coming out of the soundcard BUT somehow it was using Realtek internal soundcard, rerouting it through the Uphoria to the monitors.

  • At that point I enabled the TI PCM2902 USB CODEC which I understood to be related to the Uphoria, connected inputs an outputs from the Studio-Audio connections windows, and gladly I was able to monitor and record my guitar on an audio track. But… MIDI didn’t play anymore!!

I tried to search in the forum and elsewhere on the net for similar issues but I really didn’t find anything that suited me: I have been able to get both sounds out of my headphones singularly, so it must be a really dumb thing that a beginner like me can’t figure out;

I tried to make screenshots of some of the settings I thought to be relevant before and after the issue, if they can help; if you need more details please ask and I’ll provide them

Thanks in advance!!

MIDI sound issue.pdf (263.2 KB)

Hi and welcome to the forum,

What is the output of your MIDI Tracks? My guess is, you are using some kind of built-in audio device synth.

Please, add an Instrument track (HALion Sonic SE) and use this Virtual Instrument to generate a sound of your MIDI data. Then you can use your Audio Device (ASIO Driver) to mix all sources together.