Cubase External FX comb filter

HI all.
Im having some problems using the external FX in paralell in Cubase Pro 11. I recently started Cubase so im in a middle of some testing for my work.
One workflow i use a lot is paralell processing.
When i try to use an external compressor on a duplicate track i get some comb filtering, sounding like the compensation is not working properly like it should.

Here is the process:
Track 1 - Audio
Track 2 - Copy of same audio but using the external FX inserted ( i setup all properlly in the connections so i know its all well routed, i see some signal in the compressor and on the way back in). After i insert the plugin on channel 2 i ping the plugin gives me 0 .0ms but i have comb filtering.
Same doesn´t happen in Reaper , my other daw ( using the insert plugin - which compensates for roundtrip plus the audio interface buffer size latency)

The only method i found is to render the audio and import it back in to the session.

Thanks all.


It seems, like the delay is not really 0.0ms then. I remember some threads here on the forum, complaining the ping doesn’t work reliable for some effects.

Hi Martin… Thanks for your reply.
Yes , this is a huge drawback for me. Sometimes i need to use external gear in paralel with some tracks in your project. The only solution for now (and has been for many years ) is printing tracks.
I would like to ear from other users too, maybe not many are working this way.


If the hardware has no latency by itself, I would expect that if you insert the Input + Output Latency value (of your Audio Device Latency) to the box, this should be it. But I might be wrong.

Hi Martin, i don´t think that is the case here.
In Reaper the reported latency is measured in samples not in ms,
Reaper reports for this unit minus 489 samples ( yes, minus , negative value). When i play both original and duplicate track with insert of this external gear i get precise time alignment. Same doesn’t happen in Cubase. Maybe its because Cubase external plugin is not prepared in some how to calculate negative values so it gives me the lowest value possible, zero, which is wrong.

I´m working with a Merging Anubis audio interface, which uses AES67 over ethernet cable.
The system is setup at 48KHz, 512 buffer size and i have 32ms latency (plenty of “space” for CPU calculations on my mixing sessions). That´s why i have negative sample values for the compensation.
I have in Cubase the ASIO-guard ON and audio priority set to boost. I messed around with some settings to see if any how Cubase could not be doing proper roundtrip measurements but none worked.

I leave a print screen of reaper showing the reported latency.

I started getting 0ms ping again for my hardware when I updated to 11 from 10.5

Oh! So this can be a bug from version 11 ?
Sorry, i just recently got into Cubase, so i don’t know from past versions.
I use to have Cubase SX5 then i moved to pro tools for studio work and mixing and then i found Reaper (great DAW, lack of precise things placement and editing tools) now I’m trying to get my way back in to Cubase (i have version 11.0.10 installed), but this one gets me really disappointed. At least for one main task i do when mixing…using parallel compression on many things.

I came by to say the mystery is solved and that Cubase is actually doing what is supposed to do.
My audio interface has one option that enables an extra buffer for the ASIO hosts . By turning that off i could immediately have the external FX plugin to make the correct measure and no more comb filter introduced.

Thanks everyone for the replies

1 Like