Cubase Glitches Every 15 seconds

I have a project with about 20 tracks (mostly audio), a few plugins and VST’s (no instances of Kontakt) and a smattering of FX. Cubase 12 won’t play without glitching. Every 15secs it glitches for 1 sec. If I do a mixdown, the glitches are there, regular as clockwork. My audio buffer is at it’s max (latest version of Yamaha Steinberg USB Driver driving a Steinberg UR44C into a pair of Yamaha HS5’s). I’ve got 32Gb of RAM with c.12Gb being used. CPU is at 14%. All my libraries are on SSD’s. I’ve got a year old i7-9700 CPU @ 3.00GHz HP machine running Windows 11. I can’t produce any track as the glitches print on the wav or mp3. Playback is impossible. I’ve tried ASIO Guard on and off. I’ve changed the USB Root power options. I’ve altered the Audio Priority. I’ve activated and deactivated the Steinberg Audio Power Scheme - all to no avail. I’m tearing my hair out. Any thoughts or advice? I looked a little way back in the messages but didn’t spot this particular problem. I’d be very grateful for assistance. Many thanks in advance.

If the “glitch” is really happening at exact intervals, consider that it is coming from a trial version of some VST plugin, since that is a very common cause.

If it were caused by something else, it would not happen at precise programmed intervals.

1 Like

Thanks Steve, I appreciate your response and it’s a good shout, but I have no trial plugins running, and it glitches even if the plugins are removed. I even rendered every track within Cubase (to eliminate all the plugins from the equation) and it still glitches.

Have you eliminated a config problem in Cubase by starting in safe mode (and using that dialog to disable 3rd party VSTs?
(gotta ask, you might have, but it isn’t mentioned in your post.

Steve, I am an idiot. I forgot about the plugins on the Master Channel. One of them was an Izotope plug in that required authorisation. You were spot on with your original assessment. Thank you again for your prompt and insightful help. I really appreciate it. I’ve been throwing things at the wall! All solved now and plays perfectly.


Better to be a self-aware (temporary) idiot than an oblivious head banger!

1 Like

I’ll take that! :smiley:

thanks for this forum , I had the same problem glitched every 15 secs , isotope needed updates on master plugins. cheers lads