Cubase glitching

I’m curious if anyone else is having this problem or if it’s just me. For some reason, whenever I load in specific plugins, like Ascend Modern Grand from Heavyocity or a legato patch, Cubase starts to glitch and stutter. I’ve no idea why. I check my CPU and RAM usage and they’re both low. Any thoughts on why this happens and how to fix/combat it?


Are you loading the plugins while the audio is playing? Cubase doesn’t seem to like that much. Or, is it happening after you stop the audio, load the plugin and then hit play?

Neither, actually. I load an instrument plugin and wait for it to finish loading before I start playing. The problem occurs during playback. I play something and record the MIDI for that instrument (which also sometimes glitches out) and it’ll sometimes glitch then. I have no problems if I render the MIDI to audio, mute the instrument track, and play, though.

Cubase still glitches when I use specific instrument plugins. I’m still not sure what’s going on here. If anyone knows a possible solution and would like to share, it would be greatly appreciated!

BUMP. It’s still glitching, especially with piano libraries. I’m wondering if it’s the fact that my computer only has integrated graphics, so the CPU is trying to handle all of the audio plus visuals? I’m not sure.

Can you post an image of your Studio Setup>Audio System, with Advanced Options expanded?

Here you go!

I would try

  • using a higher audio sample buffer.
  • using the Steinberg Audio Power Scheme

I tried the higher buffer. No luck. Not sure what to do about the Power Scheme. I’ve read it cranks up your CPU usage

Of course it cranks up cpu usage.

If you want to try my suggestions, I’m happy to engage with you, if not no probelm.

Sorry I haven’t responded. I was sick. I’ll give that a try tomorrow and let you know how it goes!