Cubase global copy range ignoring muted tracks option

It appears this particular option is missing going by replies on my original question post, unless we’re mistaken. I often have loads of tracks cycling round bars 1-9 and would simply like to global copy and paste over a range of only tracks that are on at any certain moment ignoring any muted tracks. It used to be so by default in the good old days on AtarI ST.

If what you want is to select/copy the parts of all non muted tracks inside a cycle, this PLE might give a starting point:

I wouldn’t use it on its own, I would first split the loop (inside the Post-Process Commands) just to get the cycle content only.

However, I tend to disable parts instead of muting just for copy/paste purposes.

Big thanks for reply. Followed what you say but its selecting and copying all parts on unmuted tracks instead of only within cycle range (cycle activated). Tried the split loop in top line post and pre process commands. Strange we’re saying inside cycle in top box arent we. Its close tho. Wonder if its a bug or just me… this works ok for you?

Hi, just use it in the post section and before the “select all on tracks”.

Yes.

Now, things can get sensitive based on our setup, while in PLE. Not sure if you could upload a sample project or even describe a 2-3 tracks project with the parts’ margins, so that we can all have a better look, and maybe come up with a better PLE.

Hi again. Thank you for persistance and patience in assisting me here. I couldnt see how to delete my original question, not permitted or something. So I think Ive followed again what you last answered but still selecting all the parts on tracks instead of only within cycle. Even though been a long time Cubase user Im quite happy to have egg on face if I can suss this out. Ive uploaded a screenshot of a quick test project Ive just knocked up showing my PLE preset I created. Many Thanks.

Hi, I could swear that yesterday this was working. Now that I’ve recreated your example, not only it does not work, but I see that it couldn’t possibly work, the “Select All On Tracks” won’t limit to the events inside the cycle.
I’ll have another look though, even if my initial proposal to mute parts (actually the one I use) is probably the way to go unfortunately.

Yes was baffling me that one… Ive tried Select in Loop… start to cursor… neither working, to be honest youve got me half way there, Id rather keep global cutting time off the end while growing out the arrangement than carry on keep individually selecting each part and then copy paste. Surely Im not the only one who needs this option? Cheers tho man.




oh the good ol days! :stuck_out_tongue_winking_eye:

1 Like

Now, this is the closest I could get, though I don’t like it.

It will properly copy the events in cycle (after split) of the non-muted tracks. However, paste will not work as expected. One should now use the Edit->Functions->Paste To Matching Track Name. In case there are multiple tracks with the same name, we’re in trouble. Alternatively, we can hold the “channelOrganizerUndo” for the next stage, that is we first paste then apply it (can be easily done by Macro). This way, there will be no problem with identical track names.

Well done !! thank you so much, will save me so much time and keep the session flowing now. Owe u a beer! :pray: :beers:

1 Like