Cubase hangs - Cubase IC Pro will expire soon

I’m hoping Steinberg will help with this soon as reading the forum I am clearly not alone.

I have Cubase IC Pro for iPad and Cubase 7.5 with the latest SKI remote installation. Was working fine until I booted the machine today. Cubase hung at start up “initializing SKI remote extension”.

After uninstall and reinstall of SKI remote extension Cubase 7.5 starts up but now when I go to add the SKI Remote Device in Device Setup I get a pop-up window:

eLicenser Control - Message
The license for application ‘Cubase iC Pro’ will expire soon
Duration until expiration 2 hours…

At that point Cubase stops responding and I cannot hit “Ok” to dismiss the message window.

In eLicenser Control Centre there is an “All Applications” License which has the same time limit on it. I didn’t put it there to my knowledge so I guess something installed automagically.

So how do I fix this error? Am I supposed to have an eLicense for the iPad version of Cubase iC Pro - if so where does it come from because I haven’t seen anything to that effect anywhere?


Hmm, decided to try it again after a session without attempting to enable the SKI remote device.

Behold it works!

It’s a couple of hours later, one wonders if that odd license expired and cured the issue.

Will see if it comes back next weekend when I get to do another session.

Arggh!!! Spoke to soon.

Quit Cubase, ran it again and now it hangs at start up with:
“Initializing: Steinberg SKI Remote”

So it appears I now have to

  1. uninstall SKI
  2. reinstall SKI - that will get Cubase starting again
  3. run Cubase and do not activate SKI Remote device,
  4. Wait 3 hours
  5. Activate SKI device in Cubase
  6. Use Cubase iC Pro
  7. Rinse and repeat for the next session

Not Happy :frowning:

Anyone have any suggestions on how to fix this?

Okay, after getting it going again following the previously mentioned procedure I left Cubase running with Cubase Ic Pro active for a few hours. Next time I fired up Cubase it said a trial license had expired and everything continued to work

Seems stable at the moment.

Hello robw,

Are you on a PC or on a Mac?
What version of the SKI remote did you installed?
It seems that the SKI remote and the eLicenser Control Center thinks that you have the Android version installed, therefore it searches the license making Cubase hang when loading the SKI.
I am guessing that now that the Demo license has expired the eLicenser Control Center has finally realised that you have the iOS version of IC Pro and therefore you don’t require a separate license.

It is not very clear at this point what is causing this, so any information you could provide is welcome.

Best regards,


Running Windows 7 64 bit, Cubase 7.5.10.
SKI version is (latest I believe)

I had been using it just fine and then one day it started doing the above.
My iPad is set to auto update apps. I don’t know if there was an iOS update to Cubase iC Pro in the interim.

I can’t think of anything else that may have changed unless there is an auto update in windows that did something.

Not sure if this helps. Happy to supply more specific information if you have a theory to test.




I’ve just got the same issue on my iMac in version 10.8.5. Latest version installed for all eLicenser, Cubase 7.0.7 and SKI remote. I’ve opened a ticket to the support team, hope they will help me soon as this is very disturbing…


Just one maybe stupid question: what is the procedure to uninstall SKI on a Mac?



You shouldn’t be installing and reinstalling the SKI Remote every time.
Exactly what version number are you installing?
The problem is not the SKI, but the demo license on the eLicenser Control Center.
Please open the eLicenser Control Center and verify if you have a demo license for the SKI Remote.
If you have purchased Cubase IC Pro through the app store you need to wait until the DEMO license expires.

Best regards,

Thank you Guillermo for your prompt answer and advice.

I’m just wondering why everything worked perfectly until last Sunday. I use Cubase and IC Pro for a long time now. I’ve purchased IC Pro on the app store actually.

I use eLicenser and don’t see anything related to a demo license. And why do I have the same error message related to YC-3B? Moreover, YC-3B was provided with my MOX8 synthesizer, so no idea why it appears in a eLicenser message.

All those things look very strange…


I have the Same Problem. Everything Works Fine, i have the ipad app, Now cubase don’t boot it Hangs on Ski Remote. I have deinstall it and can Not use it because cubase dont boot with Ski Remote installed. Please what can i do??


Are you on a PC or on a Mac?
If you are on a Pc have you tried running Cubase as administrator?
What version of the SKI do you have installed?

To run Cubase as administrator please follow this instructions:

  • Right click on top of the application icon.
  • From the contextual menu select properties
  • Click on the compatibility tab
  • Under te privilege menu select “Run this application as administrator”

Best regards,


Just to provide a little bit more background. The technical support told me to enter YC-B3 license number in eLicenser what I did and now I don’t get the YC-B3 error anymore. Nevertheless, I still have the issue with IC Pro, even if I use it on iPad, where license is normally not needed.


Hi BHuck67

first of all sorry that Cubase is not starting up with the SKI.

Other then the license there are some other factors to check.

As Guillermo already pointed out above, giving the process enough permissions by running it as administrator might help.
The following is not only recommended if you run Cubase with the SKI remote but also as general advice to make your DAW environment more stable.
I expect the underlaying Windows up to date and to be original. Furthermore no crack tools should be installed (They often intercept connections and processes)

  • You experience a crash! Work with this standard article to rule out the most common reasons:

  • Cubase, plugins, extensions, drivers etc should always be installed for all users. Usually there is an option during installation. So if asked whether to install the program for all users or “only the currently connected user” always choose “all users”.

  • Grant exceptions for Remote SKI, Cubase etc. in all installed security programs. Both Cubase and Remote SKI request network connections from your system which might be interpreted as malicious intend (even though they are harmless).
    General computer advice: Never have more then one antivirus program on your system. Google “antivirus storm” or “AV storm” to find out more.

  • Disable all automatic system maintenance from tools like CC cleaner or other registry maintenance tools.
    They might accidentally delete or change information required by our software.
    The same as for antivirus software counts here as well: Never have more then one of those tools active on system unless you know what you are doing.

This is already a lot to check so far and should cover all basics for stable operation.

Would be nice to hear if this helps :slight_smile:


I have the same problem on Mac and Windows.


When the error message appears it should give you the option to click on “Ok” and then Cubase should continue loading.
Could you grab a screenshot of the error message or the moment where it hangs?

Also, in the Mac:
If you could open the activity monitor before loading cubase:
Go to the spyglass (search function on the right upper corner) and type “Activity”.
The activity monitor will come up on the contextual menu, select it to open it.
Then open Cubase
Once Cubase hangs look for Cubase on the activity monitor and double click on it.
From the menu that appears click on Sample.
A window will open, please save this document.

If you could send it to us it will help us a lot to find the cause of the problem.
Unfortunately we have not been able to reproduce this in-house.

Best regards,

“The license for application ‘Cubase iC Pro’ will expire soon. Duration until expiration: 4 hours 16 minutes 54 seconds”

Above the msg receive. Multiple attempts to correct problem by uninstalling remote SKI. I’m using Ipad and Win 7 and Cubase 7.5 in 64 bits. 16 gig mem and I7 processor. It started on sunday with same symptoms explain by others before. iC Pro was obtain from apple store no information to Ilock was never requested. Was working fine until last cpouple of days. Error is capable to make PC non-responsive and with a need to manually shot down.

Help requested.


Dear Steinberg corp.

As evidence by the multiple users with the same problem Ski remote is the problem. Every new installation will give the same message of the time left for its use. The download was accordingly to your support instructions and available version. Once SKI is deactivated in devices next session will not load Cubase 7.5 as it will freeze. Ski will need to uninstall from programs and features to be able to initiate another session. This will be without having IC Pro Available unless I repeat installing, activating and receiving the time limit message already posted. I believe an update of SKI remote software is due.
Hope this is corrected soon.
Thanks for the support.

Problem solve with a previous SKI version recommended by Guillermo N in other forum. The only message receive is in the IPad about not been the newest SKI file. However working better than the latest file. It confirms my interpretation that it is the latest SKI file problem.

answer and link in # 15 response of (Cubase Launch Hang/freeze stuck at SKI Remote)

Hope this help some of you guys, as it did me and a newer correct file is provided to us soon by Steinberg.