Cubase hangs during start-up

I just installed a large system update from MS (Win 10 V1709) and now Cubase hangs during the start-up process. It invokes Windows Installer during the VST Audio System initialization and then hangs. Please see attached gif file. Has anyone else encountered this problem ?

Cubase Error.GIF


Make sure your Audio Device Driver is installed and up-to-date. What Audio Device do you use?

Make sure the eLCC is up-to-date, please.

I have a Steinberg UR 824. I will do as you suggest and down load the latest USB driver. My eLCC is up to date.


I had a similar problem installing 9.5, with it hanging every time part way through…
I did as was suggested above, updating audio drivers and reinstalling UR44 drivers and it then worked first time.
Many thanks Martin for the tip.

Often the answer is simple when your pointed in the right way :slight_smile:


I have the same exact problem only i’ve tried updating everything (all drivers up to date, e-licenser etc…)
Also I’ve upgraded to AI 10 and the same exact problem persists, I have a UR22-mkII.
Please help!


Try to start Cubase as Administrator. Maybe you have no permission (when starting with user permission) to install the driver.

Try to unplug your UR22mkII and start Cubase. Does it help? If yes, plug UR22MKII back and start Cubase.

But I wonder… The system shouldn’t install the driver, when you have installed it manually.

Maybe you can try to uninstall the driver, restart computer, install the driver, restart computer, start Cubase.