Cubase iC Pro 1.2 available now!

Hello,

Cubase iC Pro v.1.2 is available now!

New Features
Tap a fader and move to the side (left or right) to reset its value to 0 dB.
Tap on a pan slider and move to the top or to the bottom to reset its value to the center or move to other fixed positions.
A sidebar menu was added on the mixer page to reset Mute/Solo/Listen/Read/Write states easily.
Gain levels of channels are displayed when moving faders.
Expanded folder tracks now appear as single tracks on project overview page.

Fixes
CICP-997 Fixes a rare phenomenon where the input level is displayed on other audio channels in the mixer.
CICP-436 Fixes several graphical issues on the project overview page.
CICP-973 Track names on mixer channel labels are no longer truncated on the left side.
CICP-949 Fixes a rare phenomenon where switching to the smallest zoom level in the mixer results in missing graphics.
CICP-939 Fixes a minor graphical issue on the IP authentication page.
CICP-802 The status of listen button now works as expected
CICP-392 Fixes a rare problem where tap tempo results in wrong results.

The SKI has been updated as well. Please download the updated SKI as well. This new SKI fixes a number of user reported problems.
http://www.steinberg.net/ski

define “soon”…

Thanks, rellay looking forward to this.

:laughing: :laughing: i think its well defined by steinberg !!
just bought an ipad and cubase ic pro… any good and useful updates are always welcome. :sunglasses:

CICP-997 Fixes a rare phenomenon where the input level is displayed on other audio channels in the mixer.

just played a little with Cubase ic pro for the first time at 4 Am after a gig !! :nerd: and i noticed this problem of wrong track metering display!! ill check it later too… hope the update solve this.

At last :smiley:


MC

What about an Android version?

It was announced somewhere else in this forum but that was over a year ago.
Thank you.

1.2 and Android versions available now!

Cant seem to update… not sure were to go
App store shows older version…
and steinberg ic pro web page buy now button not working ( yes I already own it )
on iPad same thing no update listed

Maybe try again? I’ve just downloaded the update from the iPad App Store - now to try it out :slight_smile:

All working correctly here after maybe four restarts of my Cubase software and the iPad/iPhone app. Also of note, I experience a Cubase program lockup when I leave the app running and try to close Cubase - not a full on computer lockup, just Cubase. So this seems a bit different, the app really holds onto the DAW software. (Note to self: I have to disconnect the app or I can’t close Cubase.)

Better looking mixer with better screens. Very nice, Armand, thanks for finally circling back on this app!

There is even a version a for android now ?!

Maybe you could consider Windows devices too ! :confused:

I have already set up Cubase iC Pro and tried with Cubase 6 AI. Now, I am Cubase 7.5 owner and have also updated Cubase iC Pro to v. 1.2. Before start, I have remove older version of SKI Remote (1.0.4) and installed the latest one (1.0.6.58). I repeated the set up procedure in Cubase, but could not make a connection, although iC Pro recognizes my computer and Cubase immediately upon start. I found that support OS version is iOS 6.0. Does it mean that it could not run on my iPad 2 already updated to iOS 7.0.4?
Although, could I run on the same computer two instances of SKI Remote (one for iPad and another for Android)? It looks like both installations are the same name and size ??

Alex

i use ic pro on iOS 7.0.4 (ipad 4) - works fine

What/where is the latest ?ski version? Installed the app last night along with windows 64bit ?ski and the PC is telling that the .ski version is needs to be updated. The app itself is very sluggish and the faders do not move on the MC.

Ok, so, it’s more or less working ok once the firewall issue was resolved but seems to be very cumbersome and limited outside of the pretty handy macro and function buttons, but even they fall short.

For example, click to open/add/save as/media bay and other menus etc, there’s no qwerty keyboard pop up to type a save name, no cursor or way to navigate the browsers forcing you back to share these everyday tasks with mouse and keyboard, sort of a self defeating app really!

Also, completely unable to delete markers from the track overview and it does not follow the hide track functions or jump to selected track either, which really makes it a pain to find tracks without constant swiping back and fore and that’s not very clever either.

Is this a user error or is this app really quite long in the tooth and in desperate need of updating or is it on the verge of being abandoned as not a success story?

Compared to other similar apps it is seemingly way way down in the score tables and, logic users get theirs for free!

Just purchased the pro version for an iPad v.1

Installs, have the SKI app installed on my Mac Pro… iC Pro will open up to a black blank screen.

Both iPad and Computer recognize it… is this an iPad 1 limitation or a common issue with iC Pro?

Thx.

I was planning on upgrading to an iPad 2 or 4 when I noticed the app was specced to include IOS 5, so I thought I’d give it a try on hardware I already owned… glad I didn’t get the Android Tablet I was planning on a few months ago for this app!

big~C