Cubase LE 4 Problem

Hi,

A few years ago I bought a Lexicon Alpha Sound input device that came with a free version of Cubase LE 4. I have finally decided to use this but found that the copy on the disk doesn’t actually work with my current Mac OS. It says I need at least Mac OS 10.4.0 but am running High Sierra version 10.13.6.

Have I just left it too late to use this or is there a way to get one that would work?

Any help would be appreciated.

Brian

Hi and welcome,

You can try to use Steinberg Application Installer Tool for Mac OS X. At the other hand, I would strongly recommend to update to the current Cubase version, which is compatible with the current macOS.

In your MySteinberg account (where is Cubase LE registered), you should find a voucher for the upgrade.