Cubase LE 5 Latency Problem

Hi there.

I’ve got a problem with latancy. I see that this is very common complaint and there’s numerous suggestions and recomendations for a fix. I’ve followed and implimented everything I can find, but no result. I can’t resolve the problem.

So, I’ve been to the devices > device setup > highlight the ‘ASIO DirectX Full Duplex Driver’ > control panel.

I change the buffer size sample. The default is 2048. I reduce it to 128, but it’ll only go down to 512. A buffer size of 512 is as good a useless. The latency is pronouned as ever.

Here’s the computer’s main specs:

Processor & Cache Memory: Intel® Core™ i7 Processor 720QM : GHz - 1.6 GHz, with Turbo Boost up to 2.8 GHz;
Operating System: Genuine Windows® 7 Professional, (64-bit)
Chipset: Mobile Intel® HM55 Express Chipset
Main Memory: 8GB (2GB x4) DDR3 1066 SODIMM SDRAM
Hard Drive: Dual HDD: 1 Terra Byte(500Gx2),7200rpm Dual SATA support up to 1TB (5400 rpm/ 7200 rpm)

I’ve been though all the PC optimisations and replaced drivers. All to no avail.

Any suggestions?


In your research did you notice that the number one requirement is a good soundcard supported by a well written ASIO driver?

As you do not list a soundcard in your specs I can only assume you are trying to work with the inbuilt computers sound?

The ‘ASIO DirectX Full Duplex Driver’ is the worst option. Download the ASIO4ALL driver and use that as a temporary solution until you can get a good soundcard with a dedicated ASIO driver.


Yes, that was a slight omission. On-board card unfortunatley: Intel HDA Controller (part of the HM55 chipset) from what I gather.

I tried the ASIO4ALL driver. No improvement there, and it made the VST connections unstable, so that’s not an option.

So, looks like I’m in the market for an external sound card.

Thanks for your time.