CUBASE LE 6 malfunctions in strange ways


I have had Cubase LE 6 installed for some months. It came with my NI Complete audio 6 sound card and I have bought a license after the demo period was over. It worked fine and I was starting to enjoy it.
I am running on a macbook pro and was using the OS X version before yosemite and everything was fine.

I could not find my guitar sounds from guitar rig and I understood it to be a 32 bit/64 bit issue since guitar rig was installed in 64 bit while cubase was running in 32 bit. I found I could start Cubase in 64 bit mode and thats when I started to get problems.

Cubase started ok.I could not find my ASIO driver for the Komplete audio 6. When I entered the device setup window the built in ASIO driver is displayed even if my Complete audio 6 is connected. When I try to select another driver in cubase in the device setup window, it just goes blank on me when I click the pulldown menu button.
The only buttons I can press is reset, ok or cancel.

I have now tried to remove the CUBASE LE 6 application and reinstall it without any success.
I updated to yosemise believing that might handle any OS X problems. After reinstalling CUBASE LE 6 again I get the same behavior.
I smell a driver problem here, but I cannot understand what to do.
The komplete audio 6 ASIO driver works fine when I use Guitar Rig.

Anybody seen this before?
Any ideas what is wrong and how I can fix it?

regards Raymond

Hi again. I found a solution to the problem. As I by accident had turn off the “open in low resolution”-flag when starting Cubase I got problems with Cubase trying to handle the Retina Screen. Immediately when I set the flag and restarted Cubase became its old self again and I was able to pick my Complete audio 6 driver again.

Regards Raymond