Cubase LE not recording MIDI notes from Maschine

Greetings music makers! I’m totally new to this forum so I apologize if I get anything wrong.

I’m running Cubase LE 10.5.30 with Maschine 2.0, using a MK3 controller.

I’ve created an instrument track with Maschine 2. Group inputs have been set for manual key mode on channel 1 with the start note at C3.

Midi input set to Default source on channel 1. Output set to host, channel 1. Group MIDI batch setup - sounds to MIDI notes

I can hear my kit. I can see the signal jumping on the channel but when I press record it doesn’t capture anything.

Oh, if it helps, I’m using a focusrite scarlet 2i2 as an interface. Windows 10.

Thanks for your time! I appreciate any advice you can give.

Baz

Welcome !

As I’m not familiar with Maschine, this one is difficult to grasp…

So, the most evident one, as it seems that you can hear properly your kits : are you sure that your track is record enabled (the black round button in the instrument track header - shortcut : R by default), when pressing the Record transport button ?

Hi there,

Thanks for the response! Yeah, I have the track record enabled. When I record I can see the grey bar telling me it’s recording that track but when I stop recording there are no midi notes.

I’ve attached a screenshot if that helps :slight_smile:

Baz

OK. So…

  1. Can you do also a screenshot of the Studio > Studio Setup > MIDI Port Setup pane ?

  2. Beside this (as I absolutely don’t know how the Maschine system is working), could you explain a little more these ? It’s obviously a way to describe a Maschine setup, but well…

  1. Are you sure that you have, in the Preferences > MIDI pane, the MIDI Thru Active setting enabled ?

FWIW, I’m using BFD3 with an Akai MPD32 controller. I have no issue using them both together with more or less the same setup (a pad controller triggering a drum VSTi kit via an instrument track).