Cubase LE4 Midi input

I have a problem when I try to record midi in with Cubase LE4.
My config : External USB sound card Alesis IO2 + Korg M1 connected properly (midi in to midi out, etc).
I can use the keyboard editor to insert notes with my mouse. When I play my Korg plays music, it’s OK.
I can also change Korg program number (sound) from Cubase, it works.
But when I try to record from my Korg, nothing is recorded. I can see “midi in” level in Cubase changing when a note is pressed, but nothing else.

What did I missed ? Thanks for your help.

Did you arm that particular MIDI track by clicking the red button? I don’t mean for it to sound like a silly question, but I don’t see that you’ve done this step in the things you wrote. Hope it helps.

Thanks for your answer.

Yes I have clicked on the red button. After clicking on the master record button, I can see on the midi track a grey box, bigger and bigger, but always empty, and it disappears when I click stop.

Something is even more strange ! I have added VST Hallion instrument, I have setup it in order to play have midi input from my external midi usb sound card, and it works ! I can record on Hallion track when playing on my M1 keyboard (with a big latency delay). But I can’t record on the midi track when playing on my M1… Grrrrr !

That is really weird. Here are a few other things to check for the MIDI Track:

  • *) Make sure the MIDI input routing is set specifically to receive from your Korg
    *) Make sure the MIDI track is set to receive on the same channel that your Korg is transmitting on
    *) Try putting the record mode (on left side of transport bar) to Normal
    *) Try putting the MIDI Cycle record mode (on left side of transport bar) into Mix. If it is set to Keep Last and doesn’t see MIDI coming in, then it will not keep anything and that might be why the grey box goes away after recording
    *) For the latency, you might want to check the box on the devices/MIDI devices setup panel that says something like Use System Timestamp. Sometimes that helps with latency

Not sure if these will do the trick, but hopefully they help. BTW, Cubase 5.x has a MIDI Monitor plugin that you can use as a MIDI insert. It’s really helpful for troubleshooting because it shows exactly what the particular track is (or is not) receiving. Does LE 4 have that MIDI insert plugin?

I tried everything (excepted latency because I mostly want my Korg to work) -> no change :unamused:

Another weird thing : When I go to the “keyboard editor”, notes are added from my Korg when I select “step by step input”, but not when I select “Midi input”.

I too have a grey recording box that disappears when I press stop. Did you ever find out what the answer was? I am trying to record Cakewalk SI-drumkit into cubase AI 4. i can hear the drums playing perfectly but I am unable to record them in my song.

Not sure if this is the answer to their question but it answers mine. To make the box not disappear when recording. I watched this video and it helped a lot…
so I dragged the pattern from the list and placed it a bit at a time. I noticed I still could not hear it. I had to drag it from “drum session” up to my drum kit area to hear it. It works. Using cakewalk VST SI Drum Kit in my Cubase AI 4.

Hi Jules,
If you tried everything except checking the system timestamp and nothing worked, then why not try checking the system timestamp box and seeing what it does? It’s helped me with a very similar problem in the past and, if it doesn’t help with your problem, you can always uncheck it again.

I am having this same issue, both for MIDI tracks and Instrument tracks.

I can setup my remote MIDI keyboard to send informatioover USB/MIDI and it is recoginsed by Cubase and so can play a VST (HalionOne) fo racoustic piano, which I can hear through my speakers (output). What I cannot get Cubase to do is to record anything on a track, either Instrumnet track or MIDI. I just get the grey box.

I can enter items uing the virtual keyboard and a mouse, but that is not what is required.

Any ideas? Did this original issue get a fix that worked?