Cubase licenses question

If I buy cubase 8.5, can I use that license for cubase 6? I really really dont like cubase 8/8.5 and much rather use cubase 6 but as we cannot buy that any longer (and i havent found any used in my area) i thought maybe I could buy 8.5 and use the dongle to get 6 running.

(My guess is that it wont work but cant hurt to ask)

All older versions work

Thats great, thanks :slight_smile:

Edit: Does that also apply to the Essentials versions btw? I really dont like dongles and Essentials contains everything i really need anyway.

Probably not according to this thread… unless you have an Elements version that has it’s license installed on a soft license.

http://www.steinberg.de/forums/viewtopic.php?f=226&t=97010

SeL FAQ here:

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/soft-elicenser-sel-faq.html#sel_products

Regards :sunglasses: