Cubase/Mac incompatibility

So I had a gig recording a local band at a studio I don’t normally use, and was eventually forced to use pro tools (which I’m not good at) due to Cubase misbehavior. I set up the mics, got the sounds, then when the band started tracking periodically we would hear a crackle/pop noise which was written into every track - so it had to be a computer issue. So i turned up the buffer until the band was complaining about the latency, and still the pops happened. So then I switched from 88.2 KHz to 48KHz, and suddenly the monitoring was totally screwed - the band was playing tightly, but the monitoring sounded like a marching band falling down a set of stairs. I tried rebooting Cubase and then rebooting the computer to no avail. Band is getting frustrated, so we move to pro tools - which caused more frustration because I don’t know much about it and couldn’t pull off an edit that would have required 15 seconds in Cubase.

The studio is using a Mac/high sierra. Because I don’t use real time monitoring in my normal work space (instead just using the Lynx mixer which is more flexible and has no noticeable latency), and plus, I use a PC, I’ve never come across this problem in the past. I’ve worked in that studio in the past (using my dongle - no one else in the studio uses Cubase) with no problems. The intern suggested there was an incompatibility due to an OS update together with the fact that I was using a version of Cubase that came out a year and a half ago, and I don’t believe I ever installed any of the updates on their computer. I tried to download the last update for Pro 9, but it was 13 gb and would have taken forever to download while the band is paying by the hour.

Questions: 1. has anyone else had this sort of issue? 2. can this problem be solved by updating the installation to the most recent 9 update, or would I need to buy 9.5?

Also, Today I brought the consolidated tracks into my computer, using a template I had created for the session - so control room was enabled. When I tried to disable the control room (I don’t need it for mixing, and I did want to use the audition tool which mysteriously stops working when you enable the control room) and the playback malfunctioned in terms of the tracks’ timing - the marching band thing again.

What a clusterf@ck. This could seriously impact me professionally - the band already posted on facebook mentioning it was a difficult session.

This is a Cubase issue as pro tools worked flawlessly - except, of course, for my lack of facility with it. They are using an Orion converter fwiw.


What macOS version exactly do you use? Could you try First Aid from the macOS Disk Utility?

You don’t have to download full installer (13GB) if you have installed it already. Download just an update.

I don’t use a mac; a studio in which I ran a session uses a Mac. I believe the OS is High Sierra.