Cubase midi channel problems (Akai MPK261)

Hi all

I’m having a hard time trying to get Cubase to acknowledge that my AKAI MPK261 is set to midi channel 2 and not 1. What am I missing here?

I have two midi keyboards that I want to use: one is set to midi channel 1 and the other to midi channel 2 ( I want to play both of them through Kontakt on a instrument channel running Vintage Organs, where I need two keyboards at different midi channels to play both top and bottom keys on the virtual organ). But no matter which midi channel I choose, cubase sees both of them as midi channel 1. I run both keyboards via usb midi.

Any ideas as to what I’m missing?

Cubase 7 and an Akai mpk 261. Should be simple I think.

I can get it to work fine if I run Kontakt as standalone so I’m pretty sure the problem is Cubase related.


You can set the Input Transformer of any single track to filter out a MIDI Data from a dedicated MIDI Channel.

If you want to filter out MIDI Notes of MIDI Channel 1:
Type Is | Equal | Note | And
Channel | Equal | 1

– Keep empty –


Don’t forget to enable the Module, please.

See attached screenshot, please.